Maker Pro
Maker Pro

Accuracy of division using MPY634

Hi all,

I'm doing a simple project which will do the voltage division,
Vo = 10(V1/V2). I do this using MPY634.

My connections are as below:

_____________________
V2 --- | X1(1) (14)+Vs|--- +15V
GND--- | X2(2) (12)Out| -----------
|SF(4) (11)Z1 |--- GND |
GND--- | Y1(6) (10)Z2 |--- V1 |
__|Y2(7) (8)-Vs |--- -15V |
| --------------------- |
|_________________________________|

The output that i got will be very inaccurate. For eg, when i pump in
V1=0.406V and V2=0.008V, the answer =0.0433V. The answer should be
0.019V. The measurements are done repeatedly and it shows consistent
results.

My circuit's connections are based on the data sheet of MPY634 at page
7 (Basic Divider Connection). You can refer to the datasheet at the
following webpage.

www.dodeca.ru/files/bb/mpy634.pdf

Does anybody know why this inaccuracy happen? Please advise.

Thanks,
Albert
 
L

Larry Brasfield

Jan 1, 1970
0
Hi all, Hi, one.
I'm doing a simple project which will do the voltage division,
Vo = 10(V1/V2). I do this using MPY634.

My connections are as below:

_____________________
V2 --- | X1(1) (14)+Vs|--- +15V
GND--- | X2(2) (12)Out| -----------
|SF(4) (11)Z1 |--- GND |
GND--- | Y1(6) (10)Z2 |--- V1 |
__|Y2(7) (8)-Vs |--- -15V |
| --------------------- |
|_________________________________|

The output that i got will be very inaccurate. For eg, when i pump in
V1=0.406V and V2=0.008V, the answer =0.0433V. The answer should be
0.019V. The measurements are done repeatedly and it shows consistent
results.

My circuit's connections are based on the data sheet of MPY634 at page
7 (Basic Divider Connection). You can refer to the datasheet at the
following webpage.

www.dodeca.ru/files/bb/mpy634.pdf

Does anybody know why this inaccuracy happen? Please advise.

Your results are consistent with the input offset
voltage specs for that part. The larger reason
is that analog circuits are always inaccurate to
some degree. It is up to the designer to make
sure that the accuracy is appropriate for the
application.

You may want to add a trimmer or two, or
determine what accuracy you really need
and maybe find another technique. Be sure
to consider temperature (in)stability before
deciding that trimmers will do the job.
 
Thanks, Larry.

What do you mean by "consistent with the input offset
voltage specs" and "add a trimmer"? Can you explain by giving an
example?

So, my connections are correct right?

sorry if my questions are stupid.
 
L

Larry Brasfield

Jan 1, 1970
0
Thanks, Larry.
You are welcome.
What do you mean by "consistent with the input offset
voltage specs" and "add a trimmer"? Can you explain by giving an
example?

Go to the spec sheet and find the guarantees placed
upon input offset voltage by the part manufacturer.
Measure some actual (Xin, Yin, Vout) triplets. You
will find that there is a pair (Xio, Yio) such that for
each triplet, Xin+Xio times Yin+Yio is very close
to Vout, (much closer than the errors you posted),
and both Xio and Yio are within the input offset
specification. You can think of the input offset as
a secret voltage that is added to each input with
no extra parts or effort. Your trimmer would be an
explicit circuit to add a seperate constant voltage
to each inputs. That can be easily done (for your
circuit) by putting a high value pot between the
supply rails, dividing the wiper with a resistor
divider that reduces voltage by a factor of 500
relative to ground, and using the result in place
of the grounded side of each differential input.
(See figure 2 in the spec for an almost usable
example. Just don't ground the divider output
as appears in the diagram.)
So, my connections are correct right?

I did not check them, but your results were close
enough to right that I had no reason to doubt the
connection. The input offset issue is adequate
to explain what you see and the probability of
getting there with wrong connections is very low.
And since there is a simple divider hookup in
the datasheet, and your schematic resembles
it closely, I figured you had not botched it.
sorry if my questions are stupid.

They are not stupid. They are evidence of
some learning opportunities.
 
R

Rich Grise

Jan 1, 1970
0
Thanks, Larry.

What do you mean by "consistent with the input offset
voltage specs" and "add a trimmer"? Can you explain by giving an
example?

So, my connections are correct right?

sorry if my questions are stupid.

The classic answer to this is, "The only stupid question is the one
you don't ask," but recently I saw a beer commercial that started out
looking like a laxative or hardon pill ad, but about "Taste Loss".
One of the characters asked something stupid, and the voice-over says,
"There are no stupid questions when it comes to Taste Loss..." and the
other character says, "Can you get Taste Loss from a Foosball table?"
And the voice-over says, "Let me rephrase that..."

Cheers!
Rich
 
Top