Maker Pro
Maker Pro

Amplifier repair

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
Hi anyone help!
I having problem for my amp the transistor 142/147 always burning over heating and i check the supply for dc is over suposed to be 40 v but its coming 42.5 do you think this the problem I'm just new here thanks
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,608
Joined
Nov 17, 2011
Messages
12,608
Generally I don't think that 42.5V vs. 40 V should be a problem for the transistor.

Is the transistor attached to a suitable heatsink? If so, do you use thermal grease or similar to allow the heat from the transistor to pass easily to the heatsink?
 

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
Thanks for the reply well the heatsink is the original attached. From the amp i f you know about fender perfomer1000 this the issue the problem is were using it after 30 minutes suddenly stop i check it i found the trans shotted i replaced them all it works after a few minutes its gone again i start to check the driver and other parts o did'nt any fault but the problem is the same over heating even the rsisitors too much hot can you give an idea this is a nig headache for me any suggestion..
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,608
Joined
Nov 17, 2011
Messages
12,608
What about the load? You probably overload the amp?
 

shrtrnd

Jan 15, 2010
3,826
Joined
Jan 15, 2010
Messages
3,826
Harald's right, either your load has a short in the wiring, or there was other damage to
the amp when your transistor shorted.
I'd check the cable (Ohm it out to check it).
If it looks ok, trace the circuit that feeds the transistor, to see if something else in the
transistor circuit was damaged.
 

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
I don't think it's overload, Coz i play only 25 seconds and then plof why the trasistor i geting hot even the speaker not connected, i have the same problem my friend got the fender frontman 212r almost the same problem we gave to thechnician he fixed it he use only a minute suddenly stop so we decide to check we found the trasistor shorted again we change all the transistor we check all possible damages we got the diagram i m not professional like you but i understand maybe I'm wrong did having experinces about this guitar amp? Thanks for you support we appriciates all of you thanks
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,608
Joined
Nov 17, 2011
Messages
12,608
What happens if you turn on the amplifier without input signal? Is the transistor getting hot, too?

Can you post a diagram of the circuit?
 

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
What happens if you turn on the amplifier without input signal? Is the transistor getting hot, too?

Can you post a diagram of the circuit?

Yes even without signal it'geting hot too i will send you the diagram
I send you the diagram thru manage attachment i dont if you get it otherwise please check Fender rock pro 1000 thats the model

tahnk you
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,608
Joined
Nov 17, 2011
Messages
12,608
I have no access to a fender diagram. Please attach to your post.

Also: If the transistor gets hot without signal, there is almost certainly a short circuit (or at least very low resistnace path) somewhere.
Depending on the type of amplifier another possibility is a defect bias circuit which can lead to a cross current through the power transistor(s).
 

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
check the driver and pre driver transistor.

I'll check the drivers all ok, this amp has valve 12ax7 i think the is not affecting the amp am i right? i replace all new , now working but very low power its not thesame before and its geting hot again any suggestion ,sorry is'nt it here in Bahrain only few tech can repair and they charge a lot and not reliable no guarranty as well
 

Neilapuz

Aug 5, 2012
6
Joined
Aug 5, 2012
Messages
6
I have the same problem with my performer 1000 its agood amp sound terrific but i got the problem when played outdoor it burnt i check it coz i have i little
Knowledge of repairing i test the transistor power n the driver i found the power trnsistor 142/147 are shorted i replaced yhem all i put nack i test it works but 5 minutes sudenly stop no power i open n i found the transistor r shorted i got the diagram i check evrything even the power i found the 40 volts bece 42.5 even the 16 volts become 18 volts , if the power is over it may cost the problem? Again i fixed nothing damage fir other parts now its working but very low sound n distorted also i check the transistors even no load i mean the speaker not connected no input the transistor very hot in a few minutes
Any one van help me or any suggestion i really appreciates i would rather to fix myself coz here in Bahrain only few good tech we have they charge to much without any warranty

Thanks
 
Top