Maker Pro
Maker Pro

Another one Tek 2235 power supply problem

georgegr79

Feb 24, 2017
8
Joined
Feb 24, 2017
Messages
8
Hello!
I just received yesterday my "new" 2235.Buyed really low for repair item.
Now here is the problem,when i plug it and turn it on it makes this "chew" repeated sound and the led in the face blinks.The two of the three lamps in the power supply area blinks too.
I have tested the CR960-61-62-63.Two of them found faulty (buzzer beeps on the multimeter).After i desolder them to check them again they was ok!I then tried to plug again the scope and turn it on without the two diodes.The scope turned on,without weird sounds from the supply a dot left in the screen appeared.Only the dot and i can control only the focus.
I think for a fault capacitor that maked a short circuit????
i have removed CR960-962.
What type diodes can i use?because i cant find the same.

Thanks
George
 

shrtrnd

Jan 15, 2010
3,876
Joined
Jan 15, 2010
Messages
3,876
You should find the schematic and/or maintenance manual on-line for this scope. Maybe the Techtronix web-site will have one for free.
Tek usually mark their parts with their own numbering system, different from JEDEC.
There are cross references here in the 'Resources' section, and on-line to cross reference Tek numbers to JEDEC
industry standard parts numbers that you should be able to locate easily.
Those blinking LED's should be diagnosed in the manual, as to what they mean.
 

shrtrnd

Jan 15, 2010
3,876
Joined
Jan 15, 2010
Messages
3,876
You shouldn't have a problem finding the manual online for this scope. I also own a 2235.
Tektronix doesn't make parts, they buy them from component manufacturers and install them in their equipment.
Tek usually just tells those component manufacturers to put Tek numbers on them.
(I wouldn't run that scope any more without at least replacing the parts you removed, or you may further damage
the scope).
I'm not online over weekends. If you post follow-up questions, someone here may help, or I'll be back online next week.
 

georgegr79

Feb 24, 2017
8
Joined
Feb 24, 2017
Messages
8
Does anyone knows with what type of diodes i can replace the ones that i removed?? They are working as a simple bridge as i saw in the manual
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
First, find yourself a service manual for the scope.

Second, look up the diodes and get their Tek part number.

Third, google "Tek cross-reference list" and search for that part number.
 

73's de Edd

Aug 21, 2015
3,637
Joined
Aug 21, 2015
Messages
3,637
Sir georgegr79 . . . . . . . .

I think that you are grasping for straws and / or barking up the wrong tree, those 4 diodes of the +/- 8.6 volt supply needed testing with one lead each out of circuit . . . . which you did . . . .and they passed, with good junctions .

Tell me what test equipment you have, and if having another scope that we can measure rise time of DC voltage.

In the interim, I will prep up a marked up, and all encompassing block diagram and a specific marked up schema of just the power supply section.

73s de Edd
 

georgegr79

Feb 24, 2017
8
Joined
Feb 24, 2017
Messages
8
Sir georgegr79 . . . . . . . .

I think that you are grasping for straws and / or barking up the wrong tree, those 4 diodes of the +/- 8.6 volt supply needed testing with one lead each out of circuit . . . . which you did . . . .and they passed, with good junctions .

Tell me what test equipment you have, and if having another scope that we can measure rise time of DC voltage.

In the interim, I will prep up a marked up, and all encompassing block diagram and a specific marked up schema of just the power supply section.

73s de Edd
Hello,
sorry for the late responce, was out of town
equipment available is multimeter,audio generator,rf generator,high voltage dc meter,working scope!,some types of variable power supplies

im asking for the diodes,because someone replaced 2 of them before,and i want to replace them all four with the same type.

Thanks for the help!
 

georgegr79

Feb 24, 2017
8
Joined
Feb 24, 2017
Messages
8
problem found!!!removed some old capacitors to replace them.i found tha C960 ans C961 was blown and have burned the pcb.it was a hidden under them!!!
i will replace them with new
now,can anyone please tell me what type are the diodes CR906-962??
thanks
George
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
Show us a photo and tell us what is written on them.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
Sorry, I misread that as a question about the capacitors.

Have you tried what I suggested in post 7 of this thread? If you had problems, at which step?

If you can provide a link to the service manual I can see if there is anything special about the diodes.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
I just googled for "Tek 2235 service manual".

The first hit took me here: http://www.tek.com/manual/2235-service-manual

Searching for CR960 in this document took me first to an explanation of the part of the circuit, and next to a parts list which have a description of the part and the manufacturer's part number.

They are listed as 400V 0.7A diodes of type UTR308. That diode is probably hard to find, but suggestions for replacement are a fast recovery diode like a 1N4936 which are readily available.

It DOES get easier than this, but not much.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
A quick Google for the problem you're having suggests it is caused by an overloaded power supply. One of the sides may have failed, but the problem is more likely downstream of them.
 

73's de Edd

Aug 21, 2015
3,637
Joined
Aug 21, 2015
Messages
3,637
Sir georgegr79 . . . . . . . .

INITIAL INFO :
TEK_Replacement_Diodes.png

I was prepping up a list of all of that units electyrolytic filters, as I was expecting some to be bad in the respect of that power supply going into its burst mode intermittent operation. After all, that unit has YEARS of operation behind it, and that units switch mode power supply electrolytics take a banging.
To do proper, I personally would change out the whole cluster.

Above, was the listing on the diodes that you queried about.
Your original uits were UNITRODE 200V at 750 ma units with a fast switching time spec.
If you have two of the original diodes left on the board, I would expect their cases to be of my top picture, I used to pull those out of a small UNITRODE white box of 100s to be used . . . . usually by the sets of 4' s at a time.
I now see that Tejas Instrumentations is now Sugar Daddy of UNITRODE and they must have mainly wanted their UA3840 series of switchmode controller IC technology . . . . and as for their sideline diode business . . .be damned.

I was thinking of suggesting a later UF4007 . . . . thats a hot rodded 1N4007 on the switching spec . . . . to replace those 4 units, with with a better safety threshold spec of 1KV instead of the 200V and a current uppage to 1 A instead of the 750 ma. AND that unit ALSO having the fast switching spec. . . . . . that the inverter section operates at.
I do see now that UF4000 series are being degraded to a " not used in new design category " . . . . while you can still get new old stock.

When I can no longer can get the UF4007 I guess that I will move on to one of the Philips or Vishay BEAD cases such as:

http://www.alliedelec.com/vishay-small-signal-opto-products-ssp-byv26e-tr/70061680/

73s de Edd
 
Last edited by a moderator:
Top