Maker Pro
Maker Pro

Bad inverter on a LG TV

ScArEiOuS

Jan 23, 2015
1
Joined
Jan 23, 2015
Messages
1
Hello. Some time ago my TV died. Before that, it began to die randomly. Some time later, after tuning the TV on, the image flashed for one second and that's it, and after that - didn't turn on at all. After some inspecting, i saw the image is always on the screen plus the sound is there too. So the backlight must be the problem (and I think that the power supply and mainboard must be ok). I took the TV apart and inspected the lamps. They seemed to be ok (no black zones near contacts). Then I inspected the inverter. It's a darfon v070 model. There were two smd fuses blown. I also noticed there was an LED soldered (I think it was after it was taken to a repair shop). The fuses were blown due to shorted mosfets that create AC current for lamps. Replaced those, desoldered the LED and replaced fuses. Now the lamps turn on, but only for a second. And here's where I'm stuck, I can't figure out why they don't stay on. I visually inspected all the capacitors and none of them are bulging out. I did some measurement on the main IC (OZ960). What I noticed is when i turn it on - pin 2 of that IC quickly climbs over 2 volts and then gets to 0. (pin 2 is voltage sensing pin). pin 14 (Dim control) is always at 0.8V. Datasheet states that it needs to be minimum 1.2 for low brightness, 3V max. Also, there are two inputs from motherboard - INV CTL and INV BRI. INV BRI doesn't show any voltage., while INV CTL shows nominal.

Any ideas?
Thanks.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Check that the power supply rails are stable and don't have excessive ripple.
 
Top