Maker Pro
Maker Pro

eBike Controller and LCD PCB troubleshooting/repIr


Sep 16, 2022
Sep 16, 2022
Hey all,

I am deep in the guts of my controller and LCD8S display attempting a fix and thought it worth a shot to see if anyone here has anything similar and what they did to fix it. I have a new LCD8S display on the way as I think the issue is there, but it takes about a month from China so I figured I'd work on it in the meantime as summer is winding down and I might not get to ride as much in a month.

So here goes:

My controller and LCD8S worked just fine with a 48 ZWS KT controller (square wave) and still works fine with my old YunyanKing Controller. It's a cyclone 3kW motor with a 52V 14s7p battery plus now this 48 volt SVP controller.

So shortly after riding my ebike for a few loops around the area I live in (less than 6-7 min maxing it out) I put it inside and ended up with a fault in the controller. Turns out my 270 ohm resistor had burnt out and led to downstream failure of the LM317T that steps down voltage from what should have been 52v -> 35v or so across the resistor:


Then from 35v in the LM317T input to 15V output which later goes on to the 5v stepdown section.


Anyhow, I substituted this resistor for a buck converter stepdown module that worked for a bit:


And I believe i ended up with a throttle short that somehow sent 56v to my throttle input red wire, perhaps related to a hall sensor fix that went faulty, i am thinking due to overheating the solder. This I fixed, replaced my throttle hall sensor, verified it works and speeds up the motor. At this point I attached my old YuyanKing controller and sped off zero problems at 35 mph down the street without voltage drops.

Now, I reattach my existing 48v SVP controller and even my 48v ZWS controller. I have replaced the downstream capacitor immediately after the resistor that is 270 ohm with one rated for higher voltage but same uf rating and replaced the resistor back and removed the buck converter module to eliminate possible errors and because I burnt two of them troubleshooting and well, resistors are cheaper.

I also replaced a few resistors on the LCD8S board that I determined had been slightly faulty after this short and I replaced the A1013 transistor on the LCD8S. I also wasn't sure about the status of a capacitor right above my Pin 1 above the A1013 and it read around 130 pf capacitance and I didn't have this size on hand, so replaced it with a 100 nf capacitor I had. The image below shows the resistor and capacitor I am speaking of outlined in a red box:


This worked ok to turn on the LCD as without it, the LCD didn't stay on while pushing power. I had a 302 resistor above that capacitor that was burnt that I also replaced.

So onto the interesting part:

Now, my LCD8S works just fine, turns on, displays voltage and bars, and even throttle produces power output and gives me motor power. However, on this particular model of controller (I have yet to hard test my ZWS, but presume it will be the same result) the power is being cut after I put in about 100w or so of power. I have taken numerous throttle measurements and my input power is around 4.6 v and signal is about 0.8 to start and goes up as I push the throttle down. The issue is that this cutout happens about 3-5 seconds in. It seems to correlate with the display voltage reading about 3v less that prior to throttling. So I have traced the DM pin from the Transistor and it ends up connecting to Pin 18 or VSS_4 on the STM32 processor on the LCD. I have attached my diagrams.


So it goes DM -> 104 resistor (100kOhm, reads spot on) -> 332 resistor (3.3kOhm - this resistor reads more like 3.15kOhm not sure if this is maybe contributing to my issues) -> Pin 18. I have circled the path and exit start from DM on the A1013 and ending on the STM32 pin.

I have done additional troubleshooting and have identified that DM on the Transistor reads at roughly the same voltage as base and emitter if the pin is cut. If soldered back to the pin so that it contacts the PCB it reads a lower voltage by about 3-4v.

Is it possible there is a capacitor connected to these pins that causes this drain to be greater than expected or that there is a short to a ground somewhere that eats around 3-4v?
So with this image below, the pin connections that have continuity with pin 18 (where DM traces to, through two resistors):


And for ease of view I have included and labeled STM32 printout from the reference datasheet:


Pin 18 on the processor is continuous with the following pins:
Start: Pin 18 (VSS_4) to:
Pin 12 (VSS_A)
Pin 63 (VSS_3)
Pin 60 (BOO T0)
Pin 47 (VSS_2)
This is shown on my PCB and in a diagram of the STM32 (linked above, for ease of viewing and troubleshooting).

Any suggestions on what could be causing this parasitic suck of voltage down 3 ish volts? The capacitors coming off the continuous pins actually do read around 3.3 volts on the positive side, the side not directly connected to the pins tho and not 3.3v on the side connecting to the processor, that is more of a low low voltage, I believe something like 0.08 volts or so after being stepped down from it's high of 56 volts or so throught the two resistors mentioned above.

Odd part is that the Transistor reads higher on the middle pin (56v or so) and this is my desired value. Once I connect the pin to the PCB though, it begins to read lower at 53 volts as if something downstream is sucking the voltage lower. This is where my issue begins I think. I could be wrong but it seems to be related to this.
I have also considered that maybe the high voltage on my throttle of over 4.2 (anywhere from 4.3-4.6) is causing issues and somehow preventing it to continue running. I have tried adjust various settings in the LCD programming menu also and this hasn't availed any different performance.

The motor makes a groan, and runs weakly for a bit then cuts out power. Again, with my other YunyanKing Controller it runs like a champ, given with a different phase combination. I have considered changing phase combos except that this combo worked just fine on my KT 48V ZWS until I had this resistor short on me. I was going 37mph plus and did around 200 miles before it failed on me. I do not see why switching to a sine wave would have done this. I have considered shorted Mosfets also but preliminary testing on board hasn't yielded obvious shorts, will now move to desoldering and testing each I guess.

If it helps, prior to doing anything, these were my voltage readings on the SVP controller stock from when I just received it, even before riding (voltages in red and yellow shown, switched halfway through as the yellow was easier to visualize):


And the ADC converter that came stock from the factory and voltages of the pins as taken from the rear of the board:



I am stipulating that one of the following is occuring:

1) My ADC converter is faulty, introducing a phase issue, but this seems unlikely given there is still continuity on the phase without it via the resistor and the ADC bridge input, unless programming prevents it from functioning properly by activating another phase while this one is yet working.

2) Blown mosfet(s), will be testing one by one today.

3) Blown capacitor or voltage regulator on the LCD8S but I am not sure of what the reference values are, so this is difficult to troubleshoot. Despite my detailed diagrams and mild success, I am not an electrical engineer by trade

4) Faulty throttle voltage as it's over 4.2v, unsure of real world implications of this spec, however and if that's what it's meant to be.

5) Slightly less functional resistor 332 between DM pin and VSS_4 on STM32 on LCD8S (reading 3.15 kOhm not 3.3 kOhm).

6) Faulty microprocessor either on controller, LCD8s or both.

7) ??????? Please suggest other things I may have overlooked.

This switch to sine wave has been somewhat of a headache. Please help.