Maker Pro
Maker Pro

Flashgun no longer triggers flash

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
Nikon SB800 Flashgun

Hi folks,

I opened my flashgun battery compartment door to find corrosion from some leaked batteries. I cleaned it out best I could. I started making pictures with it and heard a pop.

The popping sound was like that of a capacitor. The unit powers up, the display lights up, and it sounds like a or the cap is charging, but the flash no longer triggers or emits light. I would like to think that it is the flash tube before removing it.
I know about the high voltage and the needed discharging before disassembling the head unit.

Any help greatly appreciated and or other ideas.


Thanks


Mike
 

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
Probably (at a guess) the main discharge capacitor - something like 330μF at 350V or somesuch - you can't really miss it, being the largest component in there!

Internal pics might help.
 

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
At this point, I have only the head unit out. I have read some post, what little I could find anyway, that say the flash tube can make a popping sound when it goes out. Do you know if the these flash tubes have a filament like a bulb does. From what i can see so far, so there is no discoloration on the tube or anything suspicious.

Thanks,

sonyguy
 

Attachments

  • 20170914_174423.jpg
    20170914_174423.jpg
    213.5 KB · Views: 81

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
AFAIK the tubes are just gas-filled. You should be able to hear a high pitched whine as the power is applied and the main discharge capacitor gets charged up. The whine (whistle noise) should start quite strong then increase in frequency whilst diminishing in volume. Takes a couple of seconds for it to go through its 'range' depending on how quickly your flash mechanism can 'flash'.

If you can't hear this whine then the capacitor is likely to be dud - it's quite common, certainly more common (in my experience) than the flash tube blowing.
 

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
ok, I got this think opened up and I unsoldered the large cap. About the time I did this, I remembered that I could hear the whining charge sound and the red "test" light would come on when I powered the unit up. The display worked just no response when trying to test fire the flash.

Anyway, back to the Cap, my meter does not have the capacitance reading capability, however, I did ohm it, to charge it up some, then switched over to voltage and observed a slow voltage drop.
I checked the Cap for leaking, bulging, swelling and there was none.
I ordered me a meter, but it wont be here until Monday.

As far as I can tell, the flash tube looks good.

The battery compartment had corrosion in the upper part between the batteries and the lid. One side of the contacts were pretty tarnished. ( picture down below)

What about the trigger circuit?

The main body of the flash is separated but still connected, I'm watching videos on taking that apart.
 

Attachments

  • 20170915_110751.jpg
    20170915_110751.jpg
    384.1 KB · Views: 94
Last edited:

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
I'm making pictures during the process, so if you need more angles or a close up of an area let me know.
 

Attachments

  • 20170914_200218.jpg
    20170914_200218.jpg
    276.4 KB · Views: 100
  • 20170914_195438.jpg
    20170914_195438.jpg
    279.5 KB · Views: 101

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
About the time I did this, I remembered that I could hear the whining charge sound and the red "test" light would come on when I powered the unit up.
It's a good sign. Does the light normally change to green when it's 'ready' for use?

With the unit powered up you should be able to read a few hundred volts DC across the terminals of the big capacitor - WARNING, keep your hands well away, it can kill.... use a decent test meter, not a $2 special....

Firing the flash makes this voltage drop and thereafter the voltage should start to build back up. If the voltage is doing what it should and there's no flash then you need to look at the discharge/flash circuitry including the flash tube itself.
 

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
No the light on this one just goes to red when its ready to fire.
I got my meter in today, a day earlier than expected. I checked the capacitor and its on the money.
Time to look at the discharge/flash circuitry including the flash tube itself I guess.
 

73's de Edd

Aug 21, 2015
3,622
Joined
Aug 21, 2015
Messages
3,622
SIr Sony guy . . . . .

Here is a basic reference schematic that I have sectionalized and marked up its relevant sections.
I didn't catch this post until just now.
Looks like you now have yourself a dedicated cap tester also.
From the snippets of info that you gave, it was then possible to make some assumptions.

PSUEDO SCHEMATIC REFERENCING SOURCE:

g9Y3vz2.png


The YELLOW area is the DC-LV to -DC-HV supply unit which charges up your HV C2 flash storage capacitor.
YOUR Nikon units circuitry is much more complicated and even uses a u/p.

The GREEN area is the charge / ready inidcator for the state of charge on your C2 storage capacitor.
It uses a NE-2 neon lamp which usually fires and flashes orange when a DC voltage ramping on up to a 60-75 volts threshold is being across it. In this case, the 3.9 meg series dropping resistor has shifted that detection threshold on up towards >300 VDC. A red plastic filter is used with its orange light output.

The RED area is the main flash storage capacitor. . . . . lots of DC power gets stored up in that unit, and tracing its wiring down, shows that it is being constantly across each of the end electrodes of the flash tube.

The BLUE area is the flash tube and its trigger circuitry. The trigger circuitry is where the magic evolves.
All of the time that the main storage capacitor has been increasing its voltage level of charge, simultaneously the R2 1 meg resistor has been charging the tiny C3 capacitor . . . which it can do almost instantly . . . with it being a mere .022 ufd . . . . but its voltage level slowly raises to track the C2 charge voltage level.
By the time the READY light of NE-2 IL1 comes on . . . . . all is ready for flash time.
S2 would be your manual or test flash switch.
On your unit I would expect it to be SCR design related, so that electronic slave or bounce flash triggering could also be accomplished
For a test flash, if S2 is closed the 300 or so volts accumulated within C3 is dumped into the primary of the T2 trigger transformer which transforms it upwards to a multi kilovolt pulse at its secondary windings output which is connected to the trigger band of the flashtube.
Up until this time, that xenon gas presence within the tube was a non conductive insulator between the two opposite electrodes that are now resting at about a 350VDC charge level.
That HIGH VOLTAGE pulse causes an ionization of the xenon gas sealed within the flashtube, making it a conductive plasma now.

The end electrodes now use that conductive path to dump their charge into and . . . . KA- BAMMMMMMMMM . . . . there is being one brilliant flash of light.
Then the DC-LV to -DC-HV supply kicks in to start another capacitor charge up cycle to be ready for the next flash.

OBSERVATIONS
When you mentioned the varying charge up sound that the DC-LV to -DC-HV supply makes . . . . it starts up well loaded down by virtue of initially dumping into a depleted main capacitor and as the charge accumulates its job gets easier.
That sound shift suggests of a non leaky and properly charging main capacitor.
If the READY light comes on . . . it is charging well up into the hundreds of volts.
Triggering circuitry or flash tube is now suspect. Flash tubes usually fail by getting gassy or fai by cracking right across the the tube . . . . leaving you au partum deux.

TESTING
You can test the triggering circuit output with something you might already have .and that is a NE 2 lamp and its dropping resistor in a slim bakelite stick . . .called a Flick-R-Lite . . has been around since the '40's as a cheeeep AC line tester for power presence in home wiring.

Itsalookalikeadis . . . .mammamia

https://fthmb.tqn.com/7sdCH5O2dBnhb...bout/neon-tester-56a4a2ed5f9b58b7d0d7f061.JPG

You just connect the leads between camera shoe ground and the WHITE trigger wire that connects to the multi turns of wire band at the point shown on the Nikon parts drawing.
Then power up the flash until the ready lite light state and then manually trip the flash and expect a noticable, quick orange flash from the tester.
ALSO you might even happen to have a naked neon lamp itself . . . ( I think that my supply has declined down into the 300's )

ALTERNATIVE TEST
On this one you feed in a predermined width of aluminninny-yum-yum foil and snake round the tube such that it covers the BLUE markup. of the illustration.
Its width needs to clear the electrode at the bottom by ~1/8 in so no arc will be made to that.
on its other end its width needs to clear that trigger wire coil by a like amount, since that triger transformer secondary is being a dead short to kilovolts.
Two tabs of aluminun can come out the font so that an alli-fum-a-gator clip can hold the band in place.
Now if it were only a low humidity winter and you wore rubber soled shoes and dragged them across a wool rug and touched that new ersatz trigger band . . . . if the tube was good it would flash when your finger touched the new band.
ALAS not to be . . . . .
So you get out your electric match / fire starter . . . or cop one from the DOLLAR store.
A . . .La . . .

http://i.ebayimg.com/images/i/351020654295-0-1/s-l1000.jpg

On this unit, the central electrode arcs over to the side shell to spark . . . .
in that case an inserted insulator is needed.
On my unit, it had a small barb that it flashed to.
I just had to bend that barb back far enough so that it no longer makee sparkee . .just its HV presence from the
center pin electrode, initiated, upon a sharp piezo whacking by the trigger pull and its hammer drop gainst te piezo element .
If you will then wrap that units handle area in alum foil . . . .excepting leaving access to the trigger . . then ground the foil with a wire to the hot shoe ground.
Ready the flash up to RED light time and touch the " electric match " HV electrode tip to the new trigger band , finger trigger the match amd expect a flash emanation from a good flash tube.
If these alternate option tests for the triggering circuitry fail . . . suspect the flash tube proper.

Thasssssit . . . . .

Aside . . . . I also know what went wrong with MY Sony "XBR" series ( 500 lb tv ) that you have / had a like problem with.


73's de Edd
 

Attachments

  • upload_2017-9-18_4-29-25.png
    upload_2017-9-18_4-29-25.png
    209.6 KB · Views: 110
Last edited:

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
ah Bach! Thanks 73's de Edd. I surely appreciate this.
a simple voltage tester. I think I might have one of those around here somewhere. lol

So if I'm reading / understanding this right, the trigger / flash tube combination is basically a transistor with an illuminating emitter /collector junction albeit transparent. Instead of silicone there is a gas and no .7v forward potential breakover voltage will work here. lol

Now to put the beast back together again.

Sony XBR eh, hmmm
yep she still plays and the picture is still great. Purchased at Yakota AB Japan back around 86-87.
Were you having an intermittent problem as well. I'm on the edge of my seat waiting for the cure with anticipation...
 

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
Ok, I done a number on my flash tube and manged to tear the trigger wire off of it and awaiting two more.
Is the trigger coil supposed to have voltage on it constantly or only when you push the test fire button and or trip the shutter?
Putting this flash back together again is turning out to be a puzzle, the hard part, is getting the capacitor cover to seat.
 

73's de Edd

Aug 21, 2015
3,622
Joined
Aug 21, 2015
Messages
3,622
Sir Sony guy . . . . .

Is the trigger coil supposed to have voltage on it constantly or only when you push the test fire button and or trip the shutter?

HV from the trigger transformer is only present just after the milliseconds of time that its charged trigger capacitor has dumped its charge into it.

Any feedbacl on the trials of each of the preliminary tests . . . ? Or did you break it right away .

ahhhhhhhhhh baaaaaach . . . . . . .au Radar O'Reilly of the 477th Field Hospital Or equally as well, being spun around at the 510th Evacuation Hospital . . .China Beach.


73's de Edd
 
Last edited:

Sony guy

Jan 5, 2015
15
Joined
Jan 5, 2015
Messages
15
I wasn't able to get any feedback. I messed around and broke the trigger wire loose on the flash
tube trying to get it installed. To easen the burden for the next go around, I used blue
lock-tite to cement those rubbery bushings in.

Lol. Radar O'Reilly for the win. I didn't realize they used that line on China Beach.


Sony Guy
 
Top