Maker Pro
Maker Pro

GSM Module Issue

Embed

Jan 21, 2014
3
Joined
Jan 21, 2014
Messages
3
Hi Friends,

The following is the initialization I am doing on fibocom G610 module

String("AT&F0\r"); //Master Reset
Delay_62ms();

String("AT\r"); // Basic Command ATTENTION
Delay_62ms();

String("AT+CMGF=1\r"); // Text Mode
Delay_62ms();

String("ATE0\r"); // Echo OFF
Delay_62ms();

String("AT+CNMI=3,1\r"); // Receive Unsolicited Interrupt Enable
Delay_62ms();

String("AT+CMGD=2,4\r"); // Delete All Messages With No Conditions
Delay_62ms_Caller(15);


When i send a message as "STS"

Ascii Value of S is 53
Ascii Value of T is 54

The module is reading the message body as following 6 Byte

array_data[1]=0x35 '5'
array_data[2]=0x33 '3'

array_data[3]=0x35 '5'
array_data[4]=0x34 '4'

array_data[5]=0x35 '5'
array_data[6]=0x33 '3'

The remaining data that is date, time and message sender number are in text format only, only the message body as above.

Thank You, Good Day.:)
 

Embed

Jan 21, 2014
3
Joined
Jan 21, 2014
Messages
3
GSM Issue

Hi Mr. Harald Kapp,

The issue, the module has to read the text as STS, but it is reading as Hex, which i mentioned above.

I am sorry, please be specific,

Thank for your time and attention.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
How are you sending the "STS" message?
 

Embed

Jan 21, 2014
3
Joined
Jan 21, 2014
Messages
3
GSM Issue

Hello Mr. Steve,

I am sending that from my personal mobile handset. STS as normal text message.

I think the chip got into some configurations.

Nice to get you in this forum Mr. Steve, Thanks.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Check the documentation very carefully to see what this actually means:

String("AT+CMGF=1\r"); // Text Mode

Maybe there's a problem with it.

Try doing the setup without it and see what happens.

Try using the value 0 instead of 1.
 
Top