Maker Pro
Maker Pro

HDMI PORT NOT WORKING

Rix

Jan 9, 2021
3
Joined
Jan 9, 2021
Messages
3
I have an epson EB-X20 projector the hdmi and video ports have stopped working. I have tried resetting it and changed all leads. Even tried different devices.
All I am getting is a no signal message.
Please advise
 

Rix

Jan 9, 2021
3
Joined
Jan 9, 2021
Messages
3
Have you tried this steps:
https://files.support.epson.com/doc...ting/reference/problem_no_signal_message.html

Have you tried to connect to a monitor - just to check that it is not something else that cause this issue ?
Yes have tried othe
Have you tried this steps:
https://files.support.epson.com/doc...ting/reference/problem_no_signal_message.html

Have you tried to connect to a monitor - just to check that it is not something else that cause this issue ?
Yes I have and it's not any of the leads, even different devices same problem
 

Kabelsalat

Jul 5, 2011
176
Joined
Jul 5, 2011
Messages
176
Yes I have and it's not any of the leads, even different devices same problem
By "devices" you mean monitors or another computer ?

Please provide excact information (welcome to use the bullet list) about how you've tested on other devices?
 

Rix

Jan 9, 2021
3
Joined
Jan 9, 2021
Messages
3
By "devices" you mean monitors or another computer ?

Please provide excact information (welcome to use the bullet list) about how you've tested on other devices?
The ps4-dvd player are working on my tv but have stopped working on the projector. I did use an hdmi converter for a while in the rca input on the projector and that stopped working as well. There is nothing wrong with the hdmi leads or the hdmi converter as tried it all out on my tv and works fine.
 
Top