Maker Pro
Maker Pro

HDMI ports no longer working

Binsky734

Aug 16, 2012
1
Joined
Aug 16, 2012
Messages
1
Hello everyone. A week ago I moved into a new apartment. I brought with me my desktop computer, my HDTV, and my HD monitor. I called to get my cable set up and when the guy arrived he could not get the HDMI ports to work. We tried every port on the HDTV (there are 4) and my HD monitor (only 1 port) with two different cable boxes, and my laptop. With the cable boxes there was no response, but with my laptop the "No Signal" message went away and the laptop switched settings like it was trying to connect, but the "No Signal" message came back on. I went to try my desktop, and got the "Failed to Initialize Video BIOS" POST beep code. A quick trip to the Geek Squad informed me that my graphics card was fried. We finally got the Component connection to work for the cable box, so that is what it's running at the moment.

All of these electronic devices worked before the move, and I am kind of at a loss as to what happened. The only thing I can come up with is the fact that these electronics were transported in a new car with an all carpet interior, and put into an apartment with brand new carpet (coming from a house with bare floors), so an ESD could have damaged the electronics. Unfortunately the warranty on everything has expired, so my next step is to get a HDMI switching unit and a HDMI to Component converter box, since it appears that a HDMI to Component crossover cable is impossible (according to reviews on the crossover cables).

What I would like to know is A) What could have caused all of my HDMI ports to stop working? B) Is there any chance that I will be able to fix these ports? C) Would it be possible to build my own HDMI to Component converter box for less than a new one ($26)?

Thank You!
 

davenn

Moderator
Sep 5, 2009
14,040
Joined
Sep 5, 2009
Messages
14,040
.....................Would it be possible to build my own HDMI to Component converter box for less than a new one ($26)?

Thank You!

doubtful ... just the empty box alone without any connectors etc etc wwould cost you half of that cost.

these things are manufactured by the 1000's, they pay 50c for the box
spend the $26

Dave
 

GreenGiant

Feb 9, 2012
842
Joined
Feb 9, 2012
Messages
842
the likelyhood of blowing ALL of the hdmi ports ONLY is astronomical, there has to be something else going on here. you may want to check your hdmi cable(s) it sounds like there may be something shorting (5v to something most likely)

I can understand your video card frying, that happens, randomly, but for the video translator section to go on both your monitor and your TV at the same time with everything else working correctly on them, that sounds very weird

I recently moved as well, and had my brothers helping me, they put a fleece blanket over my TV (I didnt notice till we got where we were going) and there were many pops and crackles of static discharge when they pulled the blanket off (I winced at each one) but everything works perfectly.

I had my PC loaded into the computer case's box and it was stuffed into a styrofoam shell (lost of static there, not my best decision ever) and that is still working perfectly.

The chances of one of your pieces getting hit like that is pretty slim, especially with all of the protections incorporated nowadays, but all of them?? almost impossible

davenn,

he could probably build one for cheaper, but it wouldnt work very well, if at all
 
Top