Maker Pro
Maker Pro

help needed to fix Muff Fuzz guitar effect electronics...

M

Mister C

Jan 1, 1970
0
I picked up an old Electro Harmonix Muff Fuzz guitar effect box. Not to be
confused with "Big Muff" or "Double Muff" units. Seems pretty simple but it
is "big" to me in regards to figuring out how to fix it.

Here is what it is doing; Guitar signal passes through until I flip the
switch ON, then there is no sound.

Here are pictures of my unit...
http://misterc57.home.comcast.net/toys/muff.htm

I can use a VM and can solder repairs. The pot and the switch seem to be
working. Can anyone suggest what I should check next in trying to fix this?

Much Thanks, Mark
 
L

loedown

Jan 1, 1970
0
With the circuit being that simple, check the diodes and resistors and make
sure you have no broken leads. 1458 op amps are pretty common, so if you
still have no sound, change that.

Paul
 
M

Mister C

Jan 1, 1970
0
There is voltage on the board. With the switch ON, I can read different
voltages at the 1458, 9 volts at one pin, half that at most of the other
pins.
Could the 1458 still be bad?

I tested all the resistors and diodes "in circuit" and get readings on all.
Is it OK to test "in circuit" or do I really need to unsolder them first,
and given that there is voltage at the 1458 would that indicate the
resistors and diodes are ok?

Not sure how/where to test the final output signal.

Thank you both for your responses and help!

- Mark
 
M

Mister C

Jan 1, 1970
0
BTW, I found a couple of ICs in my parts bin labeled MC1458 CP1 KB405M with
a Motorola symbol. Am I correct in thinking this would be the right
replacement IC?

Thanks again. Mark
 
M

Mister C

Jan 1, 1970
0
Hold the presses. It is working!

Maybe I just did not have things hooked up properly before but it is working
fine and sounding great.

Thanks again for the help!
 
Top