Maker Pro
Maker Pro

Help stereo Light indicator problem on a 1976 technic SA - 5360 stereo receiver:

J0shua

Sep 16, 2017
1
Joined
Sep 16, 2017
Messages
1
Hi I am having a problem getting my stereo light indicator to light up. I even adjusted the vco with a screw driver. I get and receive live radio stations that come in just fine I just cannot get the light indicator to light up. I checked the bulb and the bulb is fine. Any suggestions on what else I could do to test or get it to work?? Any help from this thread would be amazeing. Thank you. Joshua
 

Attachments

  • 0915171504a.jpg
    0915171504a.jpg
    186 KB · Views: 86

davenn

Moderator
Sep 5, 2009
14,241
Joined
Sep 5, 2009
Messages
14,241
Hi I am having a problem getting my stereo light indicator to light up. I even adjusted the vco with a screw driver. I get and receive live radio stations that come in just fine I just cannot get the light indicator to light up.

has it ever worked and then stopped ? or have you never seen it working ?

I assume you were on FM mode ?

If it has never worked, the received signal may not be quite strong enough to active the stereo decoder and turn on the indicator
 

73's de Edd

Aug 21, 2015
3,608
Joined
Aug 21, 2015
Messages
3,608
Sir J0shua . . . . .

Firstly . . . check the units MODE pushbutton on the front panel . . . to see if it is in its STEREO position . . .if it is in MONO it will be grounding out the DC signal that activates the FM STEREO lamp indicator.

If that is the case . . . . then it would absolutely be " amazeing" . . . . (sic).

FRONT PANEL REFERENCING

http://img.canuckaudiomart.com/uploads/large/1454905-technics-sa5360.jpg

73's de Edd
 

Tha fios agaibh

Aug 11, 2014
2,251
Joined
Aug 11, 2014
Messages
2,251
Also make sure you have an external antenna hooked up. Even a cheap dipole wire antenna will do.

By the way, nice receiver. They sure made quality stuff back in the day.
 
Top