Maker Pro
Maker Pro

help with LED`s ??

stephenellis2000

Aug 14, 2012
1
Joined
Aug 14, 2012
Messages
1
Hi Guys , `im kinda new to all this electronic stuff , but anyway i am into old synthesizers in a big way , i recently took from the loft an old midi controller (a keyboard that makes NO sound of its own it just send out MIDI to control other synths) ...
Anyway it was in need of some TLC mostly cosmetic , but i decided to "spruce" up the displays by adding a 2x new cool neon blue 7 segment leds and also replacing the 3 button leds , (used for accessing different functions within the controller) to 3mm neon flashing blue units...

i de-soldered ok , and replaced with the new comps... then the problems started .. :rolleyes:

the 2x 7 segment LED`s light up ( i mean every part of both displays ) and regrdless of whatever button i press they don`t change , they just stay lit up like xmas trees ... :D

the flashing 3mm led are also very intermittent , there are 3 buttons and subsequent led...the idea being that when one button is pressed its led would light , and the others would stay off , but all of the 3 stay lit regardless of which button is pressed also the "flashing" effect is very hit and miss they will flash ok , then nothing , then two flashes in quick succession !! ??? :mad::mad::mad:

The original 7 segments and 3mm led were red by the way

i have replaced everything back to its original state and all is well again ??

any ideas folks

thanks and kindest regards

Steve
 
Last edited:

GreenGiant

Feb 9, 2012
842
Joined
Feb 9, 2012
Messages
842
have you checked the pinouts of the new vs old seven segment displays?
voltages for the old vs new displays and LED's?

Current limits for them?
 
Top