Maker Pro
Maker Pro

Hissing in ATX power supply.

kc1fx

Nov 17, 2012
7
Joined
Nov 17, 2012
Messages
7
Under load at startup, my power supply gives a loud hiss. After about a minute or so, the hissing calms down, but still is audible. I just recently replaced the 2 HV transistor pair. Would the 2 large caps in the section be causing the hissing? 680uf @ 250v OH, no load, no hiss.....
 

GreenGiant

Feb 9, 2012
842
Joined
Feb 9, 2012
Messages
842
the hissing that you hear could actually just be the fan with some dust/debris caught in it.
its possibly the caps or it could be a transformer that is hissing.
unless its a really high power one you are probably better off just buying a new one rather than spend a lot of time chasing the issue, they start around 50 or so USD for the standard ATX models
 

kc1fx

Nov 17, 2012
7
Joined
Nov 17, 2012
Messages
7
Not the fan. Yes, I could go buy another one, but I like the challenge to know I can fix it. I'm good with electronics. Strange how a transformer could cause the hissing. Basically they are just windings around a core and what is there to wear out?
 

KJ6EAD

Aug 13, 2011
1,114
Joined
Aug 13, 2011
Messages
1,114
Transformer windings vibrate and insulation wears through. They also experience thermal expansion and contraction in use which causes annular cracks in winding insulation, especially after high temperatures have embrittled the insulation.

It doesn't address the transformer matter but the white paper linked below is an excellent primer on SMPS failure modes and repair.

http://www.ti.com/general/docs/lit/getliterature.tsp?literatureNumber=slva085&fileType=pdf
 
Last edited:

QuantumCheese

Apr 27, 2012
74
Joined
Apr 27, 2012
Messages
74
I know it sounds a bit simplistic but its almost certainly one of the caps.
either the mains side smoothing cap/s or more usually the LV end.
They tend to fail quite obviously - domed top or leaking electrolyte or usually both!
If they aren't obviously damaged a capacitor meter will usually show up the fault by reading odd values instead of the expected ones. you can use an ESR meter, i find that's usually overkill.
I know PC PSU's are cheap-as-chips but i've given a new lease of life to 'quite a few' now for no more than a couple of quid.
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
The hissing sound could be instability in the control loop. It certainly could be caused by the output capacitors. It might be worth replacing them all, especially if the power supply is more than a few years old. Also, it could perhaps be the optocoupler or the TL431 (or similar) that drives it, assuming it's a dumb feedback system.

It's interesting that it stops after a few minutes. Presumably because of something warming up. It would be interesting to know whether the instability is stopping, or the transformer is just tightening up enough that you can't hear it any more. Do you have an oscilloscope? Can you look at the waveform across a secondary (any secondary) on a slower scale than the actual switching frequency, to see whether there's noise there?

Assuming the problem goes away due to something warming up, you could try spraying rapid freeze on the likely components (start with the semiconductors) to see whether the noise reappears.
 

QuantumCheese

Apr 27, 2012
74
Joined
Apr 27, 2012
Messages
74
It's interesting that it stops after a few minutes. Presumably because of something warming up. .

Its usually because a PC powers up ALL-ON, it's only when the OS takes over the power-saving modes kick in on eg. cpu & graphics card/s thus lowering the strain on the power supply.

Edit: it can also happen when the supply is on almost No load! I had one once that only made a noise when on standby. still turned out to be the smoothing cap on the Vstby output though :)
 
Last edited:

penfold

Oct 24, 2012
12
Joined
Oct 24, 2012
Messages
12
Agreeing with KrisBlue, it sounds very much like a control loop problem, the fact it only happens for a short period could be due to warming up as the capacitance and internal resistance of output caps isn't consistent with temperature so the control characteristics will change and could move into a more stable mode
 

Jeffpepin

Nov 15, 2012
13
Joined
Nov 15, 2012
Messages
13
have u try to run powersupply without mainboard ? the noise u hear is like 16khz or more ? still agressing noise from old television? .

im curious if you run directly the psup without anything connected on it if he hurl help anymore. ( green wire of atx connector on black wire)
i think i have get an old asus p4c800 E deluxe motherboard that cry like this then the mobo failed soon after
 

kc1fx

Nov 17, 2012
7
Joined
Nov 17, 2012
Messages
7
Fixed tonight

The hissing was caused by a bad 22uf 50v cap in the primary side. I used freeze spray to discovery it. So, I pulled both the caps and 1 measured 16uf and the other one 4uf. All I had was 2 33uf @ 50, so I put them in and BINGO. PURRS like the day I bought it. All together, I had 3 bad caps and one 13009 transistor. 2 of the caps were in the 3.3v output. The other was the one mentioned above. :) GREAT learning experience. It was worth the effort.

Thanks for the references I was told to look at.

Merry Christmas.
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Good work kc1fx. Merry Christmas to you too :)
 

tweakjunkie

Jan 8, 2013
10
Joined
Jan 8, 2013
Messages
10
I agree, fix it and keep it out of the landfill ! Caps, Caps, Caps, Caps !!!!
Don't discount the main filter either. Had a SWMPS with an open main filter that drove me nuts. I didn't think it would even start. It measured "Error 7" on my Sencore LC102, it was completely open.

Watch out though, if you touch the high side of the chopper on the primary, you will have curly hair.

Good luck
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
tweakjunkie, that's a great attitude.

I often spend much more than an "economical" amount of time trying to fix things. As well as learning about electronic products, learning about how components fail and which brands and types fail often and in what way, the reward of diagnosing a problem, and avoiding the expense of replacing them or buying them new, I feel very proud that I'm keeping stuff out of the landfill.

This is an uncommon attitude in today's "use it till it breaks, then throw it away and buy another" economy, although the "DIY movement" is bucking that trend.

What kind of tweaks are you a junkie of, BTW?
 

tweakjunkie

Jan 8, 2013
10
Joined
Jan 8, 2013
Messages
10
Mostly high end audio Kris. Been at it for some 30 years now.... Lotsa solder smoke inhaled. I think I brained my damage !! Nice to chat with you, heading off to bed, 1:38 am here. Later :)
 

quantumtangles

Dec 19, 2012
153
Joined
Dec 19, 2012
Messages
153
My redneck DIY PC also has a power supply issue. Very reliable since I put it together 3 years ago (motherboard, power supply, flash drive), the machine has started getting very noisy when I first turn it on.

It was only after reading this interesting thread that it dawned on me...my own power supply has precisely the same problem. It now sounds like a tractor when I first turn it on, and then becomes perfectly quiet within about 2 minutes.

On the assumption I also have an errant electrolytic capacitor, I bought some Freezing spray (just in case it is not visibly defunct...do not have an ESR meter yet).

I am going to check out whether the noise reappears after freezing suspicious electrolytic capacitors (that is a very clever idea by the way...thanks for that KrisblueNZ). But I would also like to test it with my new (second hand but new to me) oscilloscope. How might I test the caps using the oscilloscope...do I need two test leads and both channels to find a secondary wave pattern or can i use one channel and one test lead (as I only have one lead atm, connected to channel 1 from which red and black croc clips emanate)?
 
Last edited:

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
It's interesting that it stops after a few minutes. Presumably because of something warming up.

In retrospect, this was a good observation.

Also, knowing that the ESR of capacitors goes down (i.e. it gets better) with increasing temperature, this fits in well with an electrolytic capacitor fault.

It is similar to the motherboard that won't boot the first few times, then is OK until you turn it off for a while.
 

quantumtangles

Dec 19, 2012
153
Joined
Dec 19, 2012
Messages
153
In retrospect, this was a good observation.

Also, knowing that the ESR of capacitors goes down (i.e. it gets better) with increasing temperature, this fits in well with an electrolytic capacitor fault.

It is similar to the motherboard that won't boot the first few times, then is OK until you turn it off for a while.

Good to know these things. The posts about repairs are almost always interesting...of real practical use.
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
quantumtangles, a power supply that sounds like a tractor probably has a fan problem. Poke an ice block stick through the fan when it's making the noise, to stop it from turning. If the noise stops, get a new fan.

This thread is about a hissing or sizzling noise that comes from the power supply board itself.
 
Top