Maker Pro
Maker Pro

Honda MICU Breakdown

backporch

Feb 1, 2016
21
Joined
Feb 1, 2016
Messages
21
MICUnew.jpg Hello,

I have an MICU from a Honda Odyssey. The auto related forums don't appear to have too much more advice about what to do with this component, so I was hoping I might get some helpful guidance. Water has gotten into this component and resulted in some corrosion. I have not tried to separate what looks like many layers and before I break something, was wondering if anyone here had any suggestions/warnings about how to proceed. I sprayed some deoxit on the external corrosion, but it did not solve the issue.
Water entered by the pins above the circuit board and worked its way down to the bottom where there are pins that are corroded. I suspect there might be corrosion internal to this component that can't be seen until it is broken down more.
Thanks!
 
Last edited:

Martaine2005

May 12, 2015
4,963
Joined
May 12, 2015
Messages
4,963
If it’s only water Ingres, let it dry out. Once dry, you can concentrate on cleaning the corrosion.
Do you mean the PCB layers are separating?

Martin
 

backporch

Feb 1, 2016
21
Joined
Feb 1, 2016
Messages
21
Hi Martin. I don't think this board is wet anymore. but this picture is after I sprayed it down and attempted to flush the corrosion. Was much worse. Since I am still having issues, I suspect there is more corrosion under the board possibly at other connections. There are more harness connections on the underside of the board underneath the component.

I don't see any physical damage or separation of the PCB. My thought was to try and get the PCB off to do a more thorough inspection and cleaning of any additional corrosion. The board is held on with pins under the white connector at the top. I am also concerned about the corrosion on the many prongs at the bottom. I am not sure what their purpose is. If it is part of the circuitry, I suspect corrosion between the prongs. I can spray them but they do not move relative to each other.

I was reluctant to take off the board. I had recently dug into the speedometer ( issue is with dashboard light dimming) and after causing some minor adverse effects I regret that move.
 

Bluejets

Oct 5, 2014
7,053
Joined
Oct 5, 2014
Messages
7,053
Spraying, blowing out, water repellant whatever, never seem to work.
As Martin says, leave it to it's own resources to dry out on iit's own.

Had a phone drop into 3ft flood water......no amount of "drying out" by applied means did any good whatsoever.
A month later, picked it up and plugged battery back in....still works to this day.

Note:- Assuming fresh water...not salt.
 

Martaine2005

May 12, 2015
4,963
Joined
May 12, 2015
Messages
4,963
You should take the board off and clean underneath as well.
Let it dry properly.
Use IPA or similar with a soft brush all over. Getting into the pins might be an issue if they are corroded.
I would spray a contact cleaner in there and plug and unplug the connector several times to try and clean the pins by friction. The solder side might need re-soldering to clean those up.
Then check there are no shorts across any pins with a multimeter or continuity tester.

Martin
 

backporch

Feb 1, 2016
21
Joined
Feb 1, 2016
Messages
21
will deoxit satisfy same as IPA? I don't like to use my beer for cleaning.

Another reason to pull apart this component would be to exercise those rows of pins at the bottom that definitely have corrosion. Since it is installed and I think I remedied the water problem, I am going to let it sit for a little while. If the problem persists I may pull it again and dig deeper and repost here.
Thanks
 
Top