Maker Pro
Maker Pro

How to determine current

cyberwasp

Feb 26, 2013
14
Joined
Feb 26, 2013
Messages
14
I used to build circuits when I was young but life changes and I got into computers and Photoshop as a career.

I've been watching and reading tutorials on the basics to try and catch up. However I've come across a puzzle that I can't solve. I have a high power LED from a solar flood light and am trying to determine the amount of resistance needed. It was powered with 3 1.2v @2000mah nimh batteries

I'm thinking the pc board had a resistor going to the LED but it was fried along with my brain from old age! TIA
 

Alec_t

Jul 7, 2015
3,644
Joined
Jul 7, 2015
Messages
3,644
Is there a faint chance you have the actual spec of that LED? You really need to know its maximum current rating if you want to add a discrete current-limiting resistor. If the light is of oriental manufacture it may never have had one, the current being limited only by inherent resistance in the LED itself and the battery.
 

cyberwasp

Feb 26, 2013
14
Joined
Feb 26, 2013
Messages
14
Unfortunately no. The solar light was bought off of qvc. Tried looking up manufacturer for spec to no avail. The Led still lights when hooked to my bench supply at 3.6v but I don't push the ma too high as I don't want to fry it and connecting it directly to the batteries it came with is super bright. As said I
ve been out of the loop and couldn't remember if there was a way to determine current with just the battery mah and volts. Thank you for the assist!!
 

duke37

Jan 9, 2011
5,364
Joined
Jan 9, 2011
Messages
5,364
Just connect your current meter set to a current range in ONE lead between the battery and the LED.
Start with a high current range then drop it if necessary.
The current will rise very rapidly as the volts rise.
 

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
Do you have an idea of how long it ran on a charge of the battery? If so, divide 2000 by the run time in hours to get the approximate current in mA.

Bob
 

hevans1944

Hop - AC8NS
Jun 21, 2012
4,890
Joined
Jun 21, 2012
Messages
4,890
Are you sure the three 1.2V NiMH cells power the LED directly? Are there NO electronics between the battery bank and the lamp? If this is a "white light" high-wattage LED, then 3.6V may not be enough to drive it to full brightness. OTOH, connecting the LED lamp directly across these three cells may not have been the "brightest" thing to do, given that no current-limiting was provided by you.
I'm thinking the pc board had a resistor going to the LED but it was fried along with my brain from old age!
Well, if that is true, replace the resistor. Start with, say, 100 ohms, see if the LED lights, if so measure the current. Now begin reducing the resistance and record the current and the voltage across the LED each step along the way. Stop when the LED seems bright enough, or you have reached 50mA current, whichever occurs first. Have a cheeseburger. Is the LED warm to the touch? If only a little warm (or not warm at all) decrease the resistance to increase the current some more. Wash, rinse, and repeat until you reach zero resistance or the LED gets too hot to comfortably hold. Whatever current this occurs at, that's what you want your current-limiting resistor to be. Or maybe slight higher in value for cooler operation and longer life from the LED. Or perhaps you need a voltage boost circuit to achieve either of those two conditions (zero resistance or too hot to hold) because it is a "white light" LED and doesn't work really well at low voltages.

Lots of room here for some eye-opening experiments while you transition from virtual reality to real reality with real components. BTW, real components cannot be "restarted" by removing power and then applying power again. Once you "let the magic smoke out" be prepared to procure a replacement. But most of all, remember to have FUN! Electronics is supposed to be (and is) FUN! Good luck!
 

cyberwasp

Feb 26, 2013
14
Joined
Feb 26, 2013
Messages
14
Yes, there was a small circuit board but it apparently was fried somehow so I couldn't get a reading off of it. I tried your suggestion using a 200 ohm pot I had in spare parts, setting bench supply at 3.6v and slowly decreased the resistance.

To make along story short the led was cool to the touch at 120 ohms so I left it for a minute and Poof. The power supply was at 10ma. My hunch is that the led took a hit when the board was fried and it was weak already. the led was also a salvaged parts so no big loss. Am just trying to Relearn what I forgot.

In the mean time I built myself a 4 cell lithium charger using TP4056's. They haven't blew up yet!! I have a question on that but will post it separately. Thank you and everyone for your time and patience.
 
Last edited by a moderator:
Top