Maker Pro
Maker Pro

JVC 60" LED Tv problems

phlox

May 19, 2012
77
Joined
May 19, 2012
Messages
77
hi , i have a friend whose 60" JVC Led tv has a issue.
the backlight randomly goes off.Sometimes after an hour, sometimes after a few minutes.
we have removed the PSU , i then removed all the eletrolytic caps and check them, with a capacitor meter and esr meter and all of them are within tolerance. I have checked the voltages going to mainboard which were 12v and 5v. They are stable. The led's run at 159v. No voltage drop on the backlight on pin when they go off, still have a stable 5v.

i then traced around and when the backlight were off , while testing voltages on the SG3525an IC (PWM controller) the backlights suddenly came on again. all the voltages there seem fine and stable as well. however when the backlights go off, pin 10 which is the shutdown pin goes high(around 2.2v) which as per datasheet means it shuts down.Vref voltage on the IC Is stable 5v. Thinking it could be that the PWM Ic is'n functioning properly or the load on the psu gets too high and then causes the ic to go into overcurrent protection, i decided to remove the backlight adjust pin from mainboard, that worked , LED's run at half brightness but the TV has been running stable for a while now.

What would be my next step, to replace the IC or Capacitors maybe?
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Pin 10 is an input. My next step would be finding out what generates the shutdown signal. Is there a fault there?
 
Top