Maker Pro
Maker Pro

Kenwood DMX9708S Car Stereo no radio sound

ltseligman

Aug 3, 2023
3
Joined
Aug 3, 2023
Messages
3
I've had multiple Kenwood DMX9708S Car Stereos installed in my 2012 Dodge Ram 1500 Laramie. Each worked perfectly for a couple weeks, then the AM/FM radio function stopped playing sound. It seems to still receive the station's signal with the information just fine, but no sound. This is my third unit and the same thing just happened. Was working fine, then no radio sound.
All the other functions still work fine, play sound. I actually stream my radio, but this is using a ton of data on my phone! Not a good long term solution.
I found another thread on this site with the same issue that doesn't seem to find resolution. https://maker.pro/forums/threads/kenwood-receiver-no-sound-on-fm-source.109789/page-2
Wondering if anyone can shed light on what is going on? the stereo installer is also stumped.
 

Delta Prime

Jul 29, 2020
2,114
Joined
Jul 29, 2020
Messages
2,114
Wondering if anyone can shed light on what is going on? the stereo installer is also stumped.
It doesn't have that function!
I don't know what you were listening to but it wasn't the
Well look at this.
Bust out the popcorn.
EatingPopcorn.gif

 

ltseligman

Aug 3, 2023
3
Joined
Aug 3, 2023
Messages
3
Yes it does... "Radio" it is a button literally on the main screen. It worked fine at first and then... still seems ok, just no sound.
 

Delta Prime

Jul 29, 2020
2,114
Joined
Jul 29, 2020
Messages
2,114
Yes it does... "Radio" it is a button literally on the main screen. It worked fine at first and then... still seems ok, just no sound
Apologies ,for units sold in North America it comes with AM/FM radio.
It seems to still receive the station's signal with the information just fine, but no sound
I'm going to trust you with that one I'm just curious. what's the indication of the received station signal and associated information.
How did you connect your radio antenna? Where is it located?
Screenshot_20230804_041206.jpg
 

Attachments

  • B5K-0858-00.pdf
    3.6 MB · Views: 0

ltseligman

Aug 3, 2023
3
Joined
Aug 3, 2023
Messages
3
Apologies ,for units sold in North America it comes with AM/FM radio.

I'm going to trust you with that one I'm just curious. what's the indication of the received station signal and associated information.
How did you connect your radio antenna? Where is it located?
View attachment 60177
It was professionally installed. And this is the 3rd unit the same thing has happened with. I don't know where they installed the antenna, but since they have been in communication with the rep, I have to assume that is correct. Like I said, it worked perfectly for a couple weeks, all 3 times! Then, just stopped. The stations are still showing up, but I can no longer tune up and down.
 
Top