Maker Pro
Maker Pro

LED Light Fading Problem

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
Hello folks.

I have a question in regards to weak LED luminosity from a two year old radio system.
What can cause a LED to dim? I have this radio here and the left side LCD is much dimmer than the far right LCD, they are both seperate from each-other, as they are supposed to be the same lumonosity, I was wondering what causes this fading problem. You can see by one photo below that when i stand above the radio looking down that the LCD is very readable, but looking face-on to the radio, the LCD is very very dim.

I dissassembled the radio and can see that the LCD led bulb is lighting up but it is not making the LCD screen the full brightness like the other one. Pics below. This second hand radio was like this when i received it, it is a gpo brooklyn boombox manufacturered in 2017. I checked the ribbon cable to main circuit-board and it seems properly connected. Any idea's on what I can do to bring this LED back to full lumonosity? Thanks for any help. Pic's...

Michael

A 1.JPG
 

Attachments

  • A 2.JPG
    A 2.JPG
    150.4 KB · Views: 17
  • A 3.JPG
    A 3.JPG
    120.5 KB · Views: 17

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
I have more pics here and it looks like the backlight is working fine. On one of the pictures below I'm wondering if that tiny C601 capacitor could be the problem. I'm not used to messing with these tiny one's as I'm mostly used to older components. Any idea's as to what else could be causing the very dim display folks? Or is it more possible that this capacitor could be the culprit?. Thanks

A 9.JPG A 6.JPG
 

Attachments

  • A 4.JPG
    A 4.JPG
    53.3 KB · Views: 9
  • A 5.JPG
    A 5.JPG
    63.2 KB · Views: 9
  • A 7.JPG
    A 7.JPG
    167.9 KB · Views: 9
  • A 8.JPG
    A 8.JPG
    184.5 KB · Views: 9
  • A 10.JPG
    A 10.JPG
    172.3 KB · Views: 9

dave9

Mar 5, 2017
1,188
Joined
Mar 5, 2017
Messages
1,188
My first suspicion would be that this is a dodgy design where they drove the LED with too much current and/or used a generic supplier who overspec'd the allowable current.

Why do you suspect the capacitor? You could get the chip datasheet and see what the function is of the pin it's connected to, assuming you mean cap C601.

You could break the circuit to the LED somewhere and measure the current, then compare to the other side.

Your pictures do not make it clear to me, is this LED integrated into the LCD display or can it be removed and replaced? If not the latter, it may be more trouble than it's worth.
 

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
My first suspicion would be that this is a dodgy design where they drove the LED with too much current and/or used a generic supplier who overspec'd the allowable current.

Why do you suspect the capacitor? You could get the chip datasheet and see what the function is of the pin it's connected to, assuming you mean cap C601.

You could break the circuit to the LED somewhere and measure the current, then compare to the other side.

Your pictures do not make it clear to me, is this LED integrated into the LCD display or can it be removed and replaced? If not the latter, it may be more trouble than it's worth.

It does seem that the LED can be removed from the look of it now after pulling back the white sticky strip. In regards to the capacitor, I just thought it might have died, just speculation though. I cant purchase this circuit board any-where online and this radio is basically a new system built in 2017. You would think GPORetro company would sell parts but I cant find any parts from their website for this particular LCD board. I'll have a look for the datasheet, but not having much luck getting any information on this radio to be honest. This is the radio here full pic...

Hang on a second, I'll take a close up pic of the LED
 

Attachments

  • GPO Brooklyn Boombox.JPG
    GPO Brooklyn Boombox.JPG
    83.4 KB · Views: 6
Last edited:

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
I pulled back the metal tape just a tiny bit to get a better look at the LED. It looks like the LED sits into a groove on the edge of the LCD display, so it does look like I can remove it. Pic below... I compared the LED with the LED on the right hand side which is nice and bright, and it seems that the LED with the dim LCD problem is no-where near as bright. So all I have to do is find the right one and try it out.
 

Attachments

  • LED.JPG
    LED.JPG
    102.7 KB · Views: 6
  • LED 2.JPG
    LED 2.JPG
    98.8 KB · Views: 6
Last edited:

dave9

Mar 5, 2017
1,188
Joined
Mar 5, 2017
Messages
1,188
You might need to replace both to get them to match best, and personally I would still measure the current and consider if they might benefit from a little less current by swapping a series resistor.
 

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
You might need to replace both to get them to match best, and personally I would still measure the current and consider if they might benefit from a little less current by swapping a series resistor.

Yes, I'll measure the current tomorrow evening and see what they both come up with, I'll then work from there. Thanks Dave.
 

Alec_t

Jul 7, 2015
3,580
Joined
Jul 7, 2015
Messages
3,580
I'd also check to see if the values of any series resistors have gone high, or their connections have developed dry joints.
 

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
I'd try swapping the bright and dim leds to see if the problem follows.
I desoldered the LED but there is no way this LED is budging, it looks like it is seperate from the LCD screen but it seems that it is part of it but is shaped with grooves. It seems that it is all one unit but did look like it was seperate. I have a spare very bright LED from a pointing device and I put it directly on top of the dim LED shining it directly into the LCD and that did not make the LCD display any brighter either, I tried to force the LED out but had to stop before I damaged it, I'll contact the manufacturer and see if they can send me out a new LCD board first before I go any further with this.
 

Tha fios agaibh

Aug 11, 2014
2,251
Joined
Aug 11, 2014
Messages
2,251
Have you tried lightly pushing on the lcd glass to see if segments changed?

Often connections weaken or oxidize behind the lcd display or ribbon cable. If you can remove display and clean these connections, you might be able to fix it. Problem is, they can be quite fragile or glued together making it nearly impossible to fix. In which case I'd just buy another.
 

zenno

Feb 7, 2019
28
Joined
Feb 7, 2019
Messages
28
Have you tried lightly pushing on the lcd glass to see if segments changed?

Often connections weaken or oxidize behind the lcd display or ribbon cable. If you can remove display and clean these connections, you might be able to fix it. Problem is, they can be quite fragile or glued together making it nearly impossible to fix. In which case I'd just buy another.
I'm not confident enough to take the display apart as it is an awkward one. I contacted the manufacturer and the nice person on the phone said that they will send me out a replacement LCD to try, so that is something. I'll just wait for the replacement and connect it up and see how it goes, might be a few days but I'll post back for an update.

Thanks for your help
Tha fios agaibh
 
Top