Maker Pro
Maker Pro

LM317 help

vcaha

Mar 16, 2011
3
Joined
Mar 16, 2011
Messages
3
I'm trying to make a super-simple voltage regulator with an lm317. With a 5V input, I want 2.5V out and 150-200ma. According to everything I've read, 2 10ohm resistors in the following circuit should do it. But when I put my meter across v-out and ground, I get right around 5V.

I've tried different value resistors in different ratios, and for the most part it doesn't seem to affect v-out. I tried brand new LM317 and resistors, etc.

The only difference between the schematic and my breadboard is that I didn't include the caps. That might cause it to be slightly less stable, but it shouldn't keep the voltage regulation from working, should it?

Any help is greatly appreciated.
 

Attachments

  • schematic.jpeg
    schematic.jpeg
    7.3 KB · Views: 358
  • breadboard.jpg
    breadboard.jpg
    82.4 KB · Views: 775

Resqueline

Jul 31, 2009
2,848
Joined
Jul 31, 2009
Messages
2,848
What pins have you connected to what? I really can't tell from the picture. 10 ohms is a bit low value for those resistors btw., they'd run quite hot if it worked.
 

davenn

Moderator
Sep 5, 2009
14,045
Joined
Sep 5, 2009
Messages
14,045
so what made you use the 2 x 10 Ohm resistors instead of what is shown in the schematic. The schematic values are good!! :)

Dave
 

vcaha

Mar 16, 2011
3
Joined
Mar 16, 2011
Messages
3
so what made you use the 2 x 10 Ohm resistors instead of what is shown in the schematic. The schematic values are good!! :)

Dave
Because, if I understand the LM317 correctly, the ratio between the 2 resistors determines the output voltage. If the ratio is 1:1, the output voltage is 2.5v. From there, the only variable is the values of the 2 resistors, and lower resistance = higher current. So 2 10ohm resistors should give me 2.5v, and allow about 150ma of current.

What pins have you connected to what? I really can't tell from the picture. 10 ohms is a bit low value for those resistors btw., they'd run quite hot if it worked.

Ok, I did my best to redo the breadboard layout in Fritzing (see attached). Hopefully that clears it up.
 

Attachments

  • LM317_circuit.jpg
    LM317_circuit.jpg
    46.2 KB · Views: 639

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Several issues.

1) the 2 resistors set the voltage, they should not be drawing a lot of current. two 240 ohm (or 390 ohm, or 220 ohm, etc.. something around this value) resistors are appropriate.

2) What's that LED doing there? It will break things badly (as well as potentially get destroyed with the values you're using. Where that LED is connected is NOT the output.

3) if you want to use this to power LEDs (perhaps with a forward voltage of 2.5V then you need to read the sticky about driving LEDs because this is exactly the wrong way.
 

vcaha

Mar 16, 2011
3
Joined
Mar 16, 2011
Messages
3
Several issues.

1) the 2 resistors set the voltage, they should not be drawing a lot of current. two 240 ohm (or 390 ohm, or 220 ohm, etc.. something around this value) resistors are appropriate.

Ok, so it's clear to me how to use the resistors to set the output voltage, but I'm not sure how to also limit the current. I realize now I was assuming that picking resistor values for the LM317 is partly about setting the voltage, but also about lmiting the current. If I'm using two identical resistors to set the voltage, how do I calculate the current flow through those resistors?

2) What's that LED doing there? It will break things badly (as well as potentially get destroyed with the values you're using. Where that LED is connected is NOT the output.

I just used an LED so I could complete the Fritzing diagram and post it here. The real project is to power a Wii remote (which normally runs on 2xAA) from a 5V usb connection. I can see that putting an LED in my diagram was misleading. I'm not quite sure how much/little about the real application (ie: "I'm powering a wii remote from a 5v usb cable) to put into this discussion. I don't think the fact that it's specifically an Wii remote is significant, but clearly showing an LED was a bad choice.

But you say, "Where that LED is connected is NOT the output."....I'm not sure why you say that. The middle pin is the output, right? Well I'm attaching a revised diagram that hopefully makes it clearer that a resistor bridges ADJ to V-OUT, and then V-OUT goes to the load.

At any rate, I uploaded a "cleaned-up" sketch.

3) if you want to use this to power LEDs (perhaps with a forward voltage of 2.5V then you need to read the sticky about driving LEDs because this is exactly the wrong way.

...see above...
 

Attachments

  • LM317_circuit_2.jpg
    LM317_circuit_2.jpg
    35.8 KB · Views: 276

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Ok, so it's clear to me how to use the resistors to set the output voltage, but I'm not sure how to also limit the current. I realize now I was assuming that picking resistor values for the LM317 is partly about setting the voltage, but also about lmiting the current. If I'm using two identical resistors to set the voltage, how do I calculate the current flow through those resistors?

The resistors *JUST* set the voltage. In this configuration they do not limit the current.

It is possible to use an LM317 to limit current, but then it will not regulate voltage.

I just used an LED so I could complete the Fritzing diagram and post it here.

I have no idea what a fritzing is, but I'll accept that maybe you needed to put something there. But you should have told us that the diagram was not accurate.

The real project is to power a Wii remote (which normally runs on 2xAA) from a 5V usb connection.

OK, so you need a 3V regulator (approx) -- why did you decide to use 2.4V?

I'm not quite sure how much/little about the real application (ie: "I'm powering a wii remote from a 5v usb cable) to put into this discussion.

Well, starting with that tells us a lot.

I don't think the fact that it's specifically an Wii remote is significant, but clearly showing an LED was a bad choice.

Three extra characters "Wii" isn't a lot, and tells us much.

Showing a LED where you don't have one, and not mentioning it, confuses us a great deal.

Keeping your application totally secret from us means we are operating in a vacuum and may give you bad advice.

But you say, "Where that LED is connected is NOT the output."....I'm not sure why you say that. The middle pin is the output, right? Well I'm attaching a revised diagram that hopefully makes it clearer that a resistor bridges ADJ to V-OUT, and then V-OUT goes to the load.

There is a reason why circuit diagrams are used. The more I look at the original diagram the more errors I find.

And no, the new one is still completely wrong.

I'll try to draw a circuit diagram of what you should have, and what you appear to have and you'll see. (wait a few minutes...)
 
Last edited:

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
OK, here is what you should have:

attachment.php


And here is what you have:

attachment.php


Can you see the difference?
 

Attachments

  • Scan-110317-0001.jpg
    Scan-110317-0001.jpg
    11.7 KB · Views: 741
  • Scan-110317-0002.jpg
    Scan-110317-0002.jpg
    9.8 KB · Views: 758
Top