Maker Pro
Maker Pro

LM317T Voltage Regulator problem

RobertEagle

Aug 24, 2012
11
Joined
Aug 24, 2012
Messages
11
Hi,

I'm in a little dilemma with a voltage regulator. It's called LM317T
Here you have a link to it's datasheet:http://www.fairchildsemi.com/ds/LM/LM317.pdf
This is an example of a circuit: http://www.zen22142.zen.co.uk/Circuits/Power/lm317reg.gif

The R1 is 360 Oh and the R2 is 519 Oh. What I want is a voltage of 3V. In this case the math is saying that it should output 3.05, which is okay.

I've made the connections but what's giving me is almost always lower with 2 volts than the input. The resistors are fine, the bonds have no problem.

What is the problem with my wiring?
Here are some photo samples:
1.
dsc01893g.jpg

2.
dsc01892q.jpg


Thank you,
RobertEagle

PS:The green resistor is the 519 Oh one, and the other one is 360.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,615
Joined
Nov 17, 2011
Messages
12,615
1) What is the input voltage? The LM317T's dropout voltage can vary from 1.2V to 2.7 V, see figure 3 in the datasheet. Your onput voltage has to be at least Vin=Vout+Vdrop.

2) How do you measure the output voltage? Using multimeter? Chances are you`re missing an important point: your setup has no capacitors at the input and output pins of the IC (see sample application in the datasheet). Without these capacitors the LM317T may oscillate and what you're seing on the multimeter is a DC with superimposed AC. If you have an oscilloscope: measure. If not: check by using he AC range of the multimeter. In any case: add the capacitors.
 

RobertEagle

Aug 24, 2012
11
Joined
Aug 24, 2012
Messages
11
1. The input voltage is 5V. Not the dropout voltage is the problem. But the fact that the output is the same as the input voltage minus 1.5-3Volts.
I mean when I give 5V I get 3V, when I give 12 it gives me something around 10V and so on.

2. On the AC set I get 0.001V. The I2C sensor has it's own built-in capacitors for the input. And no, I don't have an oscilloscope. Just a multimeter.
 
Last edited:

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,615
Joined
Nov 17, 2011
Messages
12,615
I cannot see this clearly in the pictures, but your explanation makes it sound like R2 is not properly connected to GND (0V). In that case the LM317T would operate as a constant current source and without load would try to rasie the output voltage as much as possible - which is obvously Vin-Vdrop. It will therefore follow the input voltage.

Check your connections.
 

RobertEagle

Aug 24, 2012
11
Joined
Aug 24, 2012
Messages
11
I found what was the problem.
The bigger resistors(like 100kOhm, 300Kohm), the smaller will be the variation.
At the end, the single thing that matters is the ratio between resistors.
I'll get the same output voltage no only with 360Ohm and 519Ohm, but with 360Kohm and 519Kohm. Right?
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,615
Joined
Nov 17, 2011
Messages
12,615
Right, yes, it's the ratio that counts. But I don't see why 260 Ohm + 519 Ohm shouldn't work.
On the contrary. The equation is VO = 1.25V (1+ R 2/ R1)+IadjR2. Iadj is a (more or less) fixed term from the adjust input/output of the LM317T. The smaller R2, the smaller the error of the output voltage contributed by Iadj.

Maybe you had some loose connection and accidentally fixed this while playing with the resistors.
 
Last edited:

RobertEagle

Aug 24, 2012
11
Joined
Aug 24, 2012
Messages
11
It works actually. There are just those minor changes caused by the value of the resistors.
Aha...I get it now.(regarding the R2). It's logic.
 
Top