Maker Pro
Maker Pro

LTSpice Help

Amar Dhore

Dec 2, 2015
129
Joined
Dec 2, 2015
Messages
129
Hello Everyone,

I am new to the ltspice.
I am trying to import a third party OPAMP (MCP6L04) into ltspice. I download the spice model and added in the SPICE directories.

When I compile it, I am getting an error: "Analysis: Time steps too small; initial timepoint:trouble with node u1:21"

I have attached a .asc file. I would appreciate any help. Thanks.

--
Amar
 

Attachments

  • test1.asc
    3.6 KB · Views: 90
Last edited:

Arouse1973

Adam
Dec 18, 2013
5,177
Joined
Dec 18, 2013
Messages
5,177
Just tried it and it works for me. The OPAMP comes in as an OP37 not a MCP6L04?
Adam
 

Amar Dhore

Dec 2, 2015
129
Joined
Dec 2, 2015
Messages
129
I updated the file. Sorry about that, I forgot to save the changes.
 

Arouse1973

Adam
Dec 18, 2013
5,177
Joined
Dec 18, 2013
Messages
5,177
I don't know how good the model is. I got it to work by adding some series resistance to the power and signal sources. Also add the .options functions on the image I have posted.
Adam

SPICE.PNG
 

Amar Dhore

Dec 2, 2015
129
Joined
Dec 2, 2015
Messages
129
Yaaay, it works.Thanks Adam. I am curious to know, How did you figure it out?
 

Arouse1973

Adam
Dec 18, 2013
5,177
Joined
Dec 18, 2013
Messages
5,177
You may find it works without the gmin options but I seemed to get a faster response by adding this. The other option can solve time-step too small issues by adding a very small delay to all the nodes. I have used this a few times before and it has helped.
Adam
 
Top