Maker Pro
Maker Pro

Need help figuring out PWM output through a Mosfet

dangerbird

Aug 11, 2019
3
Joined
Aug 11, 2019
Messages
3
Hi,

I'm working on this car amplifier. The 3524 PWM chip out puts a square wave that goes to the gate of the P25N06 Mosfet. My square wave looks okay out of the PWM (although the Duty cycle is not what I expected) but the output from the Fet looks awful. I have the Fets disconnected from the transformer and each other when I test. When I breadboard the circuit the PWM output looks better, but I still get crappy output from the Fet. I've tried several different Fets and 3524 chips. What am I doing wrong?

https://www.dropbox.com/preview/Driver Test Files/Amplifier files/AmpPwr.jpg?role=personal

https://www.dropbox.com/preview/Driver Test Files/Amplifier files/Output of pin 14 and output of P25N06.jpg?role=personal


AmpPwr.jpg
 

Bluejets

Oct 5, 2014
5,985
Joined
Oct 5, 2014
Messages
5,985
Best post your photos here.
Don't think anyone wants to sign in to whatever site to view your input.
 

dangerbird

Aug 11, 2019
3
Joined
Aug 11, 2019
Messages
3
Sorry, wasn't thinking.
 

Attachments

  • AmpPwr.jpg
    AmpPwr.jpg
    138.6 KB · Views: 11
  • Outpu off pin 14 and output of P25N06.jpg
    Outpu off pin 14 and output of P25N06.jpg
    181.1 KB · Views: 9

Bluejets

Oct 5, 2014
5,985
Joined
Oct 5, 2014
Messages
5,985
Not into power system inverters but i'd say the transformer would have an effect on the output as would the frequency level.
 

dangerbird

Aug 11, 2019
3
Joined
Aug 11, 2019
Messages
3
You are probably correct. However, I have a shorted transformer, so I'll have to fix that first. Thank you for your help.
 
Top