Maker Pro
Maker Pro

Need schematic for Realistic 31-2020A graphic equalizer

Quikfix

Feb 21, 2018
2
Joined
Feb 21, 2018
Messages
2
screen has all LEDs on all the time. An old post indicates they had an issue with a series transistor in the negative supply, but that doesn't really help much... :)

If anyone knows where I can find it or post the pdf that would be great.

Thanks!
 

73's de Edd

Aug 21, 2015
3,437
Joined
Aug 21, 2015
Messages
3,437
Sir Quikfix . . . . .

If lightning actually has struck twice . . . . your same fix would be:
The marked in RED BOX . . . as being PNP pass transistor Q504.
BUT . . . an additionally blown R512 fusible resistor or shorted D503 Zener diode are equally being suspect.


RELEVANT SCHEMATIC SNIPPET . . . . .

upload_2018-2-21_3-7-32.png



73's de Edd
.....
 

Quikfix

Feb 21, 2018
2
Joined
Feb 21, 2018
Messages
2

Thanks very much! That's very helpful... it's hard to find a good (reliable, without spybots) website... looks like HIFI is not a scam/virus infested site. I was able to create an account and download the manual/schematic. I had forgotten that Realistic used to include their schematics on a bunch of their user manuals. Wish others did the same...
Thanks again.
Quikfix
 

SciFi9000

Nov 19, 2022
2
Joined
Nov 19, 2022
Messages
2
Sir Quikfix . . . . .

If lightning actually has struck twice . . . . your same fix would be:
The marked in RED BOX . . . as being PNP pass transistor Q504.
BUT . . . an additionally blown R512 fusible resistor or shorted D503 Zener diode are equally being suspect.


RELEVANT SCHEMATIC SNIPPET . . . . .

View attachment 39624



73's de Edd
.....
I realize that this is a 7-year-old post, but I picked up one of these today and all the display was lit up, then I saw this post so I had a look at the large transistors near the rectifier as shown in your image. When I jiggled on one of the transistors, it moved, so i flipped it over, retouched the solder, and presto... it works. Thank you for the post. Incidentally, I notice that the display is only effected by the right channel, is this normal? The left channel has absolutely no effect on the display. If I unplug the right channel (and keep the left connected), the display goes blank.
 

SciFi9000

Nov 19, 2022
2
Joined
Nov 19, 2022
Messages
2
screen has all LEDs on all the time. An old post indicates they had an issue with a series transistor in the negative supply, but that doesn't really help much... :)

If anyone knows where I can find it or post the pdf that would be great.

Thanks!
I just pick up one of these equalizers today with the exact same issue, it turned out to be one of the transistors with a dry solder joint as described by the old post you are referring to.
 
Top