Maker Pro
Maker Pro

NPN reverse bias reading

raju100

Oct 24, 2022
4
Joined
Oct 24, 2022
Messages
4
I am checking a Mitsubishi NPN power transistor (M67580) and see .5v drop when base emitter reverse biased. Is the transistor faulty?

The readings of voltage drops are
+B -E .549v
+B -C .556v
-B +E .534v
-B +C Infinitive
+C -E Infinitive
-C +E .508v

Please help.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
13,738
Joined
Nov 17, 2011
Messages
13,738
The M67580 seems to be a MOSFET, not an NPN transistor (link).
 

raju100

Oct 24, 2022
4
Joined
Oct 24, 2022
Messages
4
Thanks for your information.
My assumption was based on the circuit diagram from the car manual. Is it possible to check the MOSFET with DMM?

1666612635890.png
 

crutschow

May 7, 2021
852
Joined
May 7, 2021
Messages
852
If it's a MOSFET, the gate-source and gate-collector should look like an open circuit.
 

raju100

Oct 24, 2022
4
Joined
Oct 24, 2022
Messages
4
Gate-source shows .5v drop both ways. Gate-drain .5v drop and infinity in reverse.

Do you think the MOSFET is bad?
 

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
Regardless of it being a transistor (as the schematic shows) or a MOSFET as the datasheet might indicate, the fact that it reads as it does means it's dud. I'm assuming you're measuring it 'disconnected' from its circuit?
 

raju100

Oct 24, 2022
4
Joined
Oct 24, 2022
Messages
4
Thanks again Kellys.
Yes it's disconnected from circuit.
I bought a reconditioned ignition module which has the same but new transistor on it. The new transistor also gives the same readings. I doubt whether this is malfunctioning. In another forum I saw this transistor as IGBT.

It reads like this.
The Mitsu # is M67580 if this is what you are looking for. But I don't think it is available.
Also it is not a regular transistor, it is an IGBT (isolated gate bipolar transistor) specifically designed for switch ignition signals.


But my readings are not matching at all for IGBT or MOSFET. Out of 6 combinations I have 2 open and 4 closed.

Any suggestions?
 

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
Try testing it dynamically. With 12V applied to #1 and #4 connected to 0V, apply a positive voltage (via a resistor) to #3 and measure what happens at #2.

The voltage at #2 should fall to (typically) 2V for an IGBT, less for a standard Si transistor.

Of course, if the voltage at #2 doesn't drop then the transistor (or whatever) is dud.

Just for the interest value, here's a link to a nice tutorial sheet on IGBT's

 
Top