Maker Pro
Maker Pro

PIR motion sensor audio player

vijaysai1081

Jan 7, 2023
2
Joined
Jan 7, 2023
Messages
2
Hello,
I want to play audio when there is presence of human or animal. I connect

HC-SR501 Pyroelectric Infrared PIR to a simple audio(no microcontroller) chip that plays audio that is used in toys. I connected the output of PIR to the audio play pin. The issue I'm facing is when the PIR senses someone it plays the audio but it goes into a loop. The audio does not stop even when there is no one around. It just needs one trigger and it keeps on playing. Can anyone please tell me where I am going wrong. I changed the jumper settings with single trigger and multiple trigger. I used pull up resistor. None worked. I still face the same problem.

 
Last edited by a moderator:

danadak

Feb 19, 2021
271
Joined
Feb 19, 2021
Messages
271
The sensor has a delay to turn off after it has been triggered :





Regards, Dana.
 
Last edited:

vijaysai1081

Jan 7, 2023
2
Joined
Jan 7, 2023
Messages
2
The sensor has a delay to turn off after it has been triggered :





Regards, Dana.
Thanks Dana for the reply. The delay to turn off is only for how long the audio plays. I changed that. Once the audio clip completes it starts again from the beginning.
I will tell what I tried to find the error. I put the PIR sensor inside a closed box with a small opening in front of the sensor. I waved my hand in front of the hole and closed the hole. The audio started playing. Once the audio completes it should stop as the hole is closed and the sensor cannot sense anyone. But the audio does not stop it plays non stop. I want to know what is making the audio play even when the sensor is idle. If the sensor is not idle what is making to trigger continuously.

Regards vijay
 
Top