Maker Pro
Maker Pro

Poor connection made when flexing the PCB

looxuser

Dec 28, 2015
107
Joined
Dec 28, 2015
Messages
107
I have a situation where the device i'm trying to fix works intermittently and fine when i flex the pcb. If i relax the flex the board starts misbehaving again. I've checked everything under microscope and cannot see any issues. Has anyone every come across broken vias through a board please? Also there a potted IC nearby, same question?
 

Externet

Aug 24, 2009
897
Joined
Aug 24, 2009
Messages
897
I would attach the board edge? to a bench vise, a meter probe to perhaps soldered to its ground and the other probe at many places with one hand while the other hand deforms the board to get near the problem trace or solder. Yes, found open vias.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
13,769
Joined
Nov 17, 2011
Messages
13,769
cannot see any issues.
There may be a hairline crack in a trace. This type of crack is very small and almost invisible.
Also cold solder joints can lead to such a behavior. These also may be hard to detect. Re-soldering any suspect joints often helps.
anyone every come across broken vias through a board
Haven't seen that type of failure, though that doesn't mean it's not possible.
a potted IC nearby, same question?
A bonding wire may break lose within an IC housing, but that would probably be a permanent failure as the housing is stiff compared to the PCB and won't flex much.
 

Martaine2005

May 12, 2015
4,960
Joined
May 12, 2015
Messages
4,960
May also help to put pressure on each component when checking. The dry/cracked joint may show its ugly head sooner.

Martin
 

Kiwi

Jan 28, 2013
474
Joined
Jan 28, 2013
Messages
474
I have used Rapid Freeze on circuit boards looking for intermittent issues like this before. Makes any cracks to open up so they are easier to spot.
 

narkeleptk

Oct 3, 2019
74
Joined
Oct 3, 2019
Messages
74
I have a situation where the device i'm trying to fix works intermittently and fine when i flex the pcb. If i relax the flex the board starts misbehaving again. I've checked everything under microscope and cannot see any issues. Has anyone every come across broken vias through a board please? Also there a potted IC nearby, same question?
I run into this a lot with cluster repair work.
1- Bad joint on something (even if you cant see it under microscope, its there.) Usually the bigger smd components like large resistors or resistor arrays.
2- Cracked trace. Typically where it meats a via or pad and is highly stressed like a connector.

That's about it for the symptoms you describe
 

looxuser

Dec 28, 2015
107
Joined
Dec 28, 2015
Messages
107
I run into this a lot with cluster repair work.
1- Bad joint on something (even if you cant see it under microscope, its there.) Usually the bigger smd components like large resistors or resistor arrays.
2- Cracked trace. Typically where it meats a via or pad and is highly stressed like a connector.

That's about it for the symptoms you describe
many thanks going to solder through the via and see if that fixes it.
 

kingcrediepcb

Mar 24, 2023
8
Joined
Mar 24, 2023
Messages
8
I have a situation where the device i'm trying to fix works intermittently and fine when i flex the pcb. If i relax the flex the board starts misbehaving again. I've checked everything under microscope and cannot see any issues. Has anyone every come across broken vias through a board please? Also there a potted IC nearby, same question?
Hi,

Any updated news about your question? Have you fixed it?
 
Top