Maker Pro
Maker Pro

Power button on PC turns it off right after I turned it on.

Status
Not open for further replies.

Yeah Boi

Mar 24, 2018
52
Joined
Mar 24, 2018
Messages
52
Hi everyone ! When I use this button for my PC motherboard, it boots, but it turns off a few seconds after. I know the button is to blame because when shorting the pins with a screwdriver, it stays on. Also, the button diode is on when the motherboard is off, which I find weird. As you can see, I used a fan connector (that's all I had), and it fits perfectly. The pins are the right ones because the reverse does not do anything. So what is the problem ? Thank you very much in advance.IMG_0114.JPGIMG_0119.JPGIMG_0122.JPGIMG_0123.JPG
 

WHONOES

May 20, 2017
1,215
Joined
May 20, 2017
Messages
1,215
My guess is that a latching switch has suddenly become a momentary switch. If so, the only solution would be to change it.
 

Yeah Boi

Mar 24, 2018
52
Joined
Mar 24, 2018
Messages
52
Would it be ? It still turns off even if I keep the pressure. Thank you.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,613
Joined
Nov 17, 2011
Messages
12,613
My guess is that a latching switch has suddenly become a momentary switch.
I say the opposite: The power button for a PC is usually a momentary switch. press it shortly and the PC will turn on. Keep it pressed and the PC will turn off.
Supported by this observation:
It still turns off even if I keep the pressure.

I think the wiring is wrong. I see 2 wires only and 2 contacts of the switch connected:
upload_2020-11-16_7-56-29.png
To the best of my knowledge the power button on a PC works by connecting the power-on input on the motherboard to ground. The LED is powered by an extra 3rd wire. Here it seems the LED is connected across the button's contacts and thus pulls the power-on pin on the motherboard low enough to be detected as logic low, thus turning the PC off.
Use only one of the two pins for the red wire. I don't know for sure which one, my guess is the one opposing the black wire. If that works, you'll be left without indicator LED. If it doesn't work, find out which pins are for the switch and which pin is for the LED.
Use then a 3rd wire to connect the LED. consult your motherboard documentation where to connect this 3rd wire. It is likely the 3rd unused pin in the connector.
upload_2020-11-16_8-2-6.png
 

Yeah Boi

Mar 24, 2018
52
Joined
Mar 24, 2018
Messages
52
Hi ! Thank you very much to both of you. My friend realised that, despite its momentary look, the switch is a latching one, so I have to change it. Thank you again and be safe. Is there any way to mark the thread as solved ?
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,613
Joined
Nov 17, 2011
Messages
12,613
Thanks for the feedback. Unfortunately we do not have a "resolved" marker. I'll close the thread to prevent further messages herein.
 
Status
Not open for further replies.
Top