Maker Pro
Maker Pro

RC receiver failure

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
My boys RC boat quit working earlier this summer. I found and replaced a bad/unresponsive receiver board and it worked fine for a while, until the exact same thing happened again.

I then noticed a few open spots on the pcb and am thinking they omitted (to save 1c per board?) the flyback diodes next to the mosfets that forum a H bridge. Perhaps that's why these boards keep failing?
Nothing to protect ckt from inductive spikes when the motor shuts off?

What do you think, should I try buying another board and add my own blocking diodes?20180927_204737-1.jpg
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,607
Joined
Nov 17, 2011
Messages
12,607
thinking they omitted (to save 1c per board?) the flyback diodes next to the mosfets
The MOSFES's body diode acts as a flyback diode. But the body diodes of MOSFETs are not dedicated to be used as flyback diodes, so adding a few discrete ones may solve the issue.

What do you think, should I try buying another board and add my own blocking diodes?
Check the MOSFETs on the existing board first. Are they o.k.? If not, replace them. If the MOSFETs are o.k., the failure is elsewhere.

If the board (repaired old one or a new one) is running, check the temperature of the MOSFETs. Do they maybe need a heatsink? Not likely, but who knows?
 

duke37

Jan 9, 2011
5,364
Joined
Jan 9, 2011
Messages
5,364
I do not think that the MOSFET body diode will act as a flywheel diode, the polarity is wrong.

Some MOSFETs are specified on the amount of energy they can absorb when turning off. Flywheel diodes will help to reduce this energy.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,607
Joined
Nov 17, 2011
Messages
12,607
the polarity is wrong.
It is if you consider a single transistor turning a load on and off. It is not when considering an H-bridge as there is obviously in the RC controller to move the model forward and backward.

Have a look at this image:
1608_JAS_WTWH_body_diode_fig1-300x142.jpg



A simplified H-bridge looks like this (note R1 is a stand-in for a motor with a heavy inductive component - I should have drawn an inductor instead):
upload_2018-9-28_13-8-0.png

Assume M1 and M4 are on:
upload_2018-9-28_13-9-32.png

Now turn off M1 and M4, then the polarity of the voltage across R1 will invert. Current will flow through the body diodes of M2 and M3 which are correctly oriented (sorry, LTSPICE doesn't show the body diode, but check the first image for verification):
upload_2018-9-28_13-12-31.png
 

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
Thanks.
I didn't bother to check the fets because the board doesn't respond as it should so I assume the u controller took a hit.

Next to the crystal is a tiny red led that blinks when it's powered up and searching to lock onto the transmitter signal. When it locks, it then stops blinking.

This board doesn't blink anymore, so I assume when the fet got fryed the spike went through its gate to also fry the u controller.

So I'll spring $20 for another board and give it a shot.

Any diode recommendations?
Would and power diode like a 1n4007 work?
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
12,607
Joined
Nov 17, 2011
Messages
12,607
Would and power diode like a 1n4007 work?
Use a fast switching diode. The 1N4007 is probably on the slow side. Use the diode selector from the supplier of your choice.
Select for reverse voltage (probably no issue here) which needs to be at leat as high as the supply voltage of the board.
Select for forward current which need to be at least as high as the max. motor current as the diode will have to carry that current when it takes over.
 
Top