Maker Pro
Maker Pro

[SIMPLE CIRCUIT HELP/ANALYSIS] LEDs driven by GameBoy sound

HLF

Oct 28, 2018
1
Joined
Oct 28, 2018
Messages
1
Hello!

My circuit does not work as I thought it should and I'm really confused now.


What I want?
Two LEDs which will pulse to audio LEFT and RIGHT channel separately.
And same for display BACKLIGHT, but there is going to be SPDT switch, which will switch between direct voltage or voltage from transistor - in order to react to sound.


So far I have >> THIS << . (The transistor is BC337)

1.) It works when I don't use power supply of GameBoy but external for the circuit. >> This is how it looks like. <<
2.) LEDs with no transistor will light UP when I use GameBoy power supply.
3.) Somebody told me before to put ground from audio to actual ground, not to emitter, but it works like that. When I tried to connect it to ground it stopped working. But still don't know why it works with audio ground on emitter.
4.) It is really weird, but when I switch the switch, it works as expected, BUT it switch LEDs not BACKLIGHT.

I really can't find any logical explanation in my head. I started with electronics few days ago, so there must be things I cannot see.

Thanks in advance!
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,507
Joined
Jan 21, 2010
Messages
25,507
Can you post your image here. I can't see it on my phone when you post it on that external site.
 

darren adcock

Sep 26, 2016
463
Joined
Sep 26, 2016
Messages
463
Are you copying the circuit from somewhere? Can you post it on here?

A brief look at the circuit; Others will tell me if i'm wrong, I think you should have each of your LED's (load) between your + supply and the collector of the BC337, with an appropriate (current limiting) resistor. Then the Emitters tie to ground?

Best to post your circuit here though, so you can get the answer you require and learn how you went wrong etc....

In fact here is the circuit you had on an external link;

aw6bJvT.png
 
Top