Maker Pro
Maker Pro

Simpson 260 series 5, Ohms won't zero out

Kid Shalleen

Feb 26, 2014
3
Joined
Feb 26, 2014
Messages
3
I have two voltmeters I am attempting to rehab which have the identical problem. One is the Simpson 260 series 5, and the other is an Eico 565. In both cases the only way I can get a positive deflection of the needle is in the highest range settings, and even then it doesn't zero out. It will only go about 2/3 to 3/4 scale, Rx1 and Rx10 both deflect negative when the leads are crossed. All batteries (4-AA and 1-D cell, both cases) are new. Ohm-ed the leads out and swapped them with another set. Though I now not associated I did read 3 different DC voltages and two AC voltages with both meters, successfully. One meter doing this is enough to drive me to distraction, but two!?!? Coincidentally, I got both meters from the same guy at the same time. Is there any chance, do you think, that he may have screwed up two times with each meter by checking a voltage of sufficient level to cause both problems? Also, a physical inspection of both meters along with a sniff test lead to no indication of anything having smoked. So all you Batmen out there, "Riddle me this"? :confused:
 

davenn

Moderator
Sep 5, 2009
14,273
Joined
Sep 5, 2009
Messages
14,273
hi there

an initial thought that there may be trimpot resistors for each of the Ohms ranges that may need adjusting ??

post some sharp and well lit pics of the internals of the meters, it may help someone see a problem

cheers
Dave
 

Kid Shalleen

Feb 26, 2014
3
Joined
Feb 26, 2014
Messages
3
I found my problem. As often happens it was operator, or in this case, repairman error. Not having a schematic for either meter at the time, I repaired the Simpson by cleaning up the battery leakage problem and the Eico's smashed battery holder was replaced, but I erroneously linked the 1-D cell and 4-AA batteries in parallel when they should have been in series. The easy check for this (which is how I found it) is to check from the common (-) probe point to the (+) probe point, and I read 1.5 vdc.As soon as I saw that, I knew immediately what I had done. One big forehead slap for me. Thanks for the response from down under, Mate!
 

davenn

Moderator
Sep 5, 2009
14,273
Joined
Sep 5, 2009
Messages
14,273
outstanding :)

nice to sort out a problem, even if self inflicted ...
Its all a learning experience ;)

Dave
 
Top