Maker Pro
Maker Pro

soldering station Weller PU 81

newton

May 18, 2010
5
Joined
May 18, 2010
Messages
5
Hello to all forum...
I am a new member of the forum.
I have a problem with the soldering station WELLER PU 81 that I would repair: after I press the power button breaks the fuse.
I would need the electrical schematic for this station, someone can help me?

thanks a lot.
 

Tesla

May 10, 2010
165
Joined
May 10, 2010
Messages
165
We had many older Weller stations (I'm sure a different model from yours) at my old shop, and they occassionally failed (but were repaired by us). We used and abused them and they kept working.

Most failures revolved around broken or shorted wires/connectors in the cord that goes to the soldering iron pencil itself (ultimately to the heating element).

Unplugged from AC power, "ohm-out" your wires in cords. Also, check your heating element for proper ohms.

I suppose your could unplug the pencil and cord and see if it still blown fuses ... it might help you isolate the problem.
 
Last edited:

newton

May 18, 2010
5
Joined
May 18, 2010
Messages
5
Hello Tesla
I thank you for the information and help you gave me.
I found electrical schematic, I did some checks and found a broken D2 1N4001 ( see attached file).
After replacing the diode soldering station has returned to work correctly.
Thank you very much!
 

Attachments

  • PU 81 part_1.zip
    89.5 KB · Views: 1,913
  • PU 81 part_2.zip
    90 KB · Views: 1,598

Tesla

May 10, 2010
165
Joined
May 10, 2010
Messages
165
You are welcome.

Good job on the trouble-shooting and repair.
 
Top