Maker Pro
Maker Pro

Sony SDM-HS75 No Power

A

alllw

Jan 1, 1970
0
I have this Sony LCD monitor (SDM-HS75) that will not power on. Not
even 2 years old and hardly used once a week. Power on indicator not
illuminated. The power supply is build-in....no power brick used. I
have the Sony service manual but all it really shows you is how to
disassemble the monitor. No schematic! Hopefully just a fuse but
won't know that till I open her up. So if there is anyone with any
tips on fixing this monitor I would really appreciate some help.

Thanks, Al
 
J

JANA

Jan 1, 1970
0
The factory service does not service these at the component level. They swap
boards, and re-adjust them to match if necessary. Component servicing
something complex at the component level is more expensive for a factory
service department than to simply swap out a board or two to make something
work.

If the power supply has failed, the proper fix is to order a replacement
board from Sony. It is possible that something else in the monitor may have
caused the failure. You will find out when you try the new board.

You may find it more feasible to take the monitor to a Sony service centre.
This will avoid you from having to buy boards to try, and then be stuck with
them after if they are not required.

Considering the advancements in LCD monitors and their price drops, your
monitor may not be feasible to service.

--

JANA
_____


I have this Sony LCD monitor (SDM-HS75) that will not power on. Not
even 2 years old and hardly used once a week. Power on indicator not
illuminated. The power supply is build-in....no power brick used. I
have the Sony service manual but all it really shows you is how to
disassemble the monitor. No schematic! Hopefully just a fuse but
won't know that till I open her up. So if there is anyone with any
tips on fixing this monitor I would really appreciate some help.

Thanks, Al
 
A

alllw

Jan 1, 1970
0
Update:

Just got my monitor back from Sony Service in San Diego, took less
than 7 days. Repair was done under warranty...thought it was 1 year
but it was for 3 years.

The description of parts or service reads :

Reset - IC F-F33
Constant No Power
Replaced Parts

I did notice before I sent it in was that the back cover was
discolored where the power supply circuits are. (over heating?)

OK, at least it's working now.

Al
 
Top