Maker Pro
Maker Pro

Swing Gate Opener Help

mikesir

Jan 22, 2020
2
Joined
Jan 22, 2020
Messages
2
I have a Viking T-21 swing gate opener (first gen). It operates off (2) 12 volt batteries in series. We recently bought (2) new batteries to replace the old batteries because after visual inspection the old ones had started to bulge and the terminals had corroded to the point they were not connected at all. It is no longer charging the batteries, after powering down for roughly an hour or so to let all power bleed off, & powering back up, I am only getting 2 volts on the battery leads (batteries disconnected), and there should be 28 volts according to tech support. Short of sending this board in for repair/replacement, does anyone have any ideas on what may have failed on the board to create this condition?
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
13,187
Joined
Nov 17, 2011
Messages
13,187
May I assume that with the old batteries, bulged as they were, the gate still worked?
So the electronics ust have been o.k. up to that point.
It is no longer charging the batteries,
How do you know? Did you measure the charge current?
The low voltage at the output wothout batteries may be a protection feature of the board. The board may sense the presence of a battery (I don't know whether it does) and apply higher voltae and current only if a working battery is detected. Measure charge current by connecting he batteries with an ammeter in series.
 

mikesir

Jan 22, 2020
2
Joined
Jan 22, 2020
Messages
2
May I assume that with the old batteries, bulged as they were, the gate still worked?
So the electronics ust have been o.k. up to that point.

How do you know? Did you measure the charge current?
The low voltage at the output wothout batteries may be a protection feature of the board. The board may sense the presence of a battery (I don't know whether it does) and apply higher voltae and current only if a working battery is detected. Measure charge current by connecting he batteries with an ammeter in series.
Have you checked the fuses?
Yes fuses have been checked and were good. I thought the same thing, battery protection, so i hooked batteries back up, charge current was .4 amps, batteries were right off the shelf and at approx. 50%. But you just made me think of something, yes the gate worked but the terminals on the batteries had corroded and fallen off. The only way that's possible is another 24 volt DC supply somewhere, would explain why the batteries were bulging.
 

Tha fios agaibh

Aug 11, 2014
2,249
Joined
Aug 11, 2014
Messages
2,249
What may have failed on the board to create this condition?
Possibly nothing. When a battery starts to go bad they often won't take a charge (bad cell) and will release excessive hydrogen gas.
This gas causes corrosion at the battery terminals and can cause the case to bulge.

If your new batteries have about 25- 28v hooked up, their probably fine. If you get 5 years or more out of a lead acid battery, consider yourself lucky.
 
Top