Maker Pro
Maker Pro

switch mode power supply makes a clicking

Eng.Moath

Nov 2, 2022
3
Joined
Nov 2, 2022
Messages
3
i have a lab. device that I have repaired a part of it and I've done the mission but while I was assemply the device the SMPS didn't work, after I inspected the board no thing was diffictive but I heared a klicking sound from the transformer with high freq. while it connected to the device and low freq. when I disconnect the device (load) from the MSPS, please help me to find the problem
 

Attachments

  • 20221102_203107.jpg
    20221102_203107.jpg
    510 KB · Views: 13
  • 20221102_203041.jpg
    20221102_203041.jpg
    463.9 KB · Views: 13

kellys_eye

Jun 25, 2010
6,034
Joined
Jun 25, 2010
Messages
6,034
I have repaired a part of it
What was originally wrong with it and what did you do to fix it?

I'd use IPA (isopropyl alcohol) to clean up the flux around that IC first....... and fix Q1 to the heatsink properly too.
 

Eng.Moath

Nov 2, 2022
3
Joined
Nov 2, 2022
Messages
3
What was originally wrong with it and what did you do to fix it?

I'd use IPA (isopropyl alcohol) to clean up the flux around that IC first....... and fix Q1 to the heatsink properly too.
Actually I repaired another part, the SMPS was working great
 

Alec_t

Jul 7, 2015
3,455
Joined
Jul 7, 2015
Messages
3,455
A clicking power supply could indicate that it's being overloaded and going into self-protect mode by shutting down intermittently.
 

Eng.Moath

Nov 2, 2022
3
Joined
Nov 2, 2022
Messages
3
A clicking power supply could indicate that it's being overloaded and going into self-protect mode by shutting down intermittently.
Great, I knew that through my search but I couldn't find any caps or resistor burned out I'm really tired
 
Top