Maker Pro
Maker Pro

Tektronix 2235 o-scope power supply smoke

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
We were using my 2235 to do some repairs in some warm weather outside when the rear of the unit with a bright light smoked and flashed, I'm sure from the PS portion of the scope. It was quickly disconnected and later put on the bench. The unit was opened and the PS area heavily inspected, we found absolutely no damage, burn marks, of any kind anywhere.

The unit was plugged in and tested using an isolation transformer and variac to full power and there were no issues. everything functioned normally. it was shut off and allowed to cool and turned back on without variac and isolation, continuing to function normally.

Since then I haven't used it becuase I don't know what smoked. does anyone have any ideas, perhaps one or more electrolytics in the PS.

thank you,

Jordan
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
one thought I'd that maybe some insect got itself totally cooked by high voltage. If you've seen and heard this happening in things designed to kill insects then you'll realize how much it sounds like something burning out.

Another possibility is that a film cap across the meetings decided to give up. Al though to do so without obvious damage or a blown fuse seems unlikely.
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
You would think that there would be some trace of the event in the case..... regardless of what it was. My guess is a capacitor. I can't recall how many electrolytics are in the PS area or what size they are
 

shrtrnd

Jan 15, 2010
3,826
Joined
Jan 15, 2010
Messages
3,826
If I'm reading your post correctly, after the flash your scope was found to be functioning normally.
If you lost a cap, it wouldn't be.
I tend to agree with *steve*'s assessment.
Combustible gas near whatever you were working on, an insect, something not related to the internal workings of your scope.
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
I wasn't satisfied with the fact that it could have been a bug. Also intermittent issues put the scope on the bench again....

Surprise surprise C904 Toasted

iaxUppYJ772


https://plus.google.com/+JordanRubin6502/posts/iaxUppYJ772


Where do I order another one of these... also its obscured by the power receptacle. Unfortunately it uses nuts on the back so I will have to carefully remove it

Jordan
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
You'll probably want to clean that PCB too.
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
Thanks for the tip...... do you know the part number for C904 or what type of capacitor it is?
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
I'm not sure which component C904 is. Is it the metal box? I'd go to a dedicated tektronix forum or mailing list for the best information. I'm sure these have failed before :)
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
It lies directly behind the power switch (rear) as shown in the link
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Probably some sort of film capacitor. See here. also see page 13 of this.

C904 is shown as polarized and has a value of "2200" I believe it is far more likely to be an unpolarized mains rated 2.2nF (2200pF) capacitor.
 
Last edited:

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Damn rookie mistake :-( Go here: http://www.ko4bb.com/manuals/index.php?dir=Tektronix/Tektronix_-_2235 The manuals I attempted to point you to are the fifth and eighth (last) respectively.

The capacitor you suggest is not normally placed across the mains, but I've seen it done.

More typically you'll use an X or X2 rated capacitor (see here).

The original may have been something like this: https://www.digikey.com/product-detail/en/P278HE222M480A/399-12057-ND/5272272

The closest amazon (gasp) match is http://www.amazon.com/Capacitors-66...UTF8&qid=1438561597&sr=1-9&keywords=2200pf+X2
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
That's true. The cap is not polarized. The schematic symbol is incorrect
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
I was hoping the replacement of C904 would finally bring this issue to an end


https://plus.google.com/+JordanRubin6502/posts/EdBUxjBjT9L

unfortunately the problem persists and is exhibited in the following two videos. Im hoping that from this someone might have an idea as to where I should look next in the never-ending quest to get this scope functional again.


 

dorke

Jun 20, 2015
2,342
Joined
Jun 20, 2015
Messages
2,342
I watched the clips but could not understand what is the problem.
In the clips you keep working the knobs without saying what you are doing,and what seems to be the problem.
Could you explain in words?
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
I watched the clips but could not understand what is the problem.
In the clips you keep working the knobs without saying what you are doing,and what seems to be the problem.
Could you explain in words?

Watch the top video seconds 4 through 10 and then 14 through 16 21 through 24 and so on... You will see the horizontal go flaky like something is loose in the unit
 

JRUBIN

Jul 17, 2015
96
Joined
Jul 17, 2015
Messages
96
Ok so it seems like this issue only exists in Horizontal Mode A (and ALT obviously to the extent A is involved with ALT) However when in B mode the scope works fine with no issues. Id hope this would narrow down the cause, the movie below elaborates on the issue.


Apparently This setting deals with which sweep generator is used (page 2-6 of the operators manual)

I believe sweep generator A is BLOCK 3 of the block diagram which may be disassociated with Alternate B in BLOCK 5

From TM 11-6625-3135-40 page 1-4

Al MAIN CIRCUIT BOARD ASSEMBLY (C) — Provides instrument working voltages and processes vertical and horizontal signals.

A5 ALTERNATE SWEEP CIRCUIT BOARD ASSEMBLY (D) — Processes Alternate B Sweep horizontal signals.

From TM 11-6625-3135-40 page 1-8

A Sweep Generator and Logic Circuit (fig. FO-8)
Alternate Sweep Logic Circuit (fig. FO-9)


A SWEEP GENERATOR AND LOGIC CIRCUIT. The A sweep generator logic circuit controls A Sweep generation and Z-Axis unblinking. When the A TRIGGER mode switches are set to either P-P AUTO or TV FIELD (with no trigger signal present), a reference sweep is produced. In the NORM setting, sweeps are inhibited until a trigger input is present. This is useful for low-repetition-rate triggering. The SGL SWP setting allows only one sweep at a time to be generated. The sweep signal is applied to the horizontal amplifier.


ALTERNATE SWEEP LOGIC CIRCUIT. The alternate sweep logic circuit controls the alternate and B horizontal mode displays, intensity, Z-Axis amplifier drive level, and includes the B Miller sweep generator and B sweep logic circuitry. It also provides the B sweep sawtooth waveform and generates signals to control switching between the A and B displays.


From TM 11-6625-3135-40 page 2-21

Monitor A4R701 (161) pin 1 for approximately -8 vdc ±50 mv, as switch is turned through all TIMING ranges. ● If voltage varies more than 5 mV, replace A4 (para 2-20).


From TM 11-6625-3135-40 page 2-47

A4 TIMING CIRCUIT BOARD ASSEMBLY REPLACEMENT
 
Last edited:
Top