Maker Pro
Maker Pro

Tektronix 2235 scope power supply problem

Phil Nelson

Jul 5, 2010
5
Joined
Jul 5, 2010
Messages
5
Hi, new member here . My Tektronix 2235 oscilloscope developed a power supply problem. It makes a HV-like squeak about once per second and two little LEDs on the main board blink. No trace appears, even when I press and hold the beam find button.

I replaced two electrolytics in the power supply (C906, 75uf/450v, and C925, 100uf/25v). The problem is unchanged.

I have restored tube radios and TVs, but I don't have good equipment (or eyesight) for working on solid state boards like this.

My next guess would be to replace the four rectifier diodes (CR901, CR902, CR903, CR904), but I don't want to start shotgunning everything in sight.

Ideas?

Thanks!

Phil Nelson
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
If it's making intermittent noise like that, then it sounds like something is overloaded and is shutting down to protect itself.

If you're right, then it may be the EHT supply. The failure may be due to something shorting it to earth. You could look for black spots or streaks, or cracks in the EHT cable.

Just be careful because even what looks like a dead short at several thousand volts can be an open circuit at many hundred volts -- there still may be a charge remaining, and it could bite you.

At the sight of an EHT power supply, I put my hands in the air and start backing away. Please don't expect much help from me :D
 

Phil Nelson

Jul 5, 2010
5
Joined
Jul 5, 2010
Messages
5
I replaced two electrolytics in the power supply, electrolytics, C906, 75uf/450v, and C925, 100uf/25v. No improvement. The four diodes in the bridge rectifier (CR901-CR904) test OK. I also tested resistors R888-R891, which someone warned me about. All of them are OK.

I guess the power supply is going into fail-safe mode to prevent damage from a short circuit or whatnot. I disconnected the lead to the HV (EHT) rectifier block. Again, no change.

Presumably the problem lies somewhere between the bridge rectifier and the HV rectifier(excluding those four resistors), but that still leaves plenty of components!

Phil Nelson
 

davenn

Moderator
Sep 5, 2009
14,077
Joined
Sep 5, 2009
Messages
14,077
Hey Phil,
good surname there buddy, something we share :)

before randomly swapping any more components....

1)... If you can get a service manual do so e-baman is a great place to start for free downloads, got my tek 465B manual from there
2)... with or without the manual chances are the pcb will have markings showing various voltage rails coming out of the PSU to various sections of the scope ... check all of them and see how far they vary from what is stated. then you can isolate sections of the system on that power rail and narrow down the problem location.
3)... there are a couple of great tektronix yahoo groups that are very active and have been
a good help to me I suggest checking them out and asking a few Q's .. could be very productive :)

cheers
Dave
 

Phil Nelson

Jul 5, 2010
5
Joined
Jul 5, 2010
Messages
5
Thanks, I do have a thorough manual, mentioned in the second post. The part numbers are taken from that manual.

I tried measuring output voltage for the various supplies, but my DMM was all over the place. In this "blinking" fail-safe mode, it restarts about once per second and never seems to reach a steady state. Perhaps it is worth trying to measure something again.

The Yahoo groups sound like they are worth checking out. I appreciate the suggestions.

Regards,

Phil Nelson
 

davenn

Moderator
Sep 5, 2009
14,077
Joined
Sep 5, 2009
Messages
14,077
Thanks, I do have a thorough manual, mentioned in the second post. The part numbers are taken from that manual.

I tried measuring output voltage for the various supplies, but my DMM was all over the place. In this "blinking" fail-safe mode, it restarts about once per second and never seems to reach a steady state. Perhaps it is worth trying to measure something again.

The Yahoo groups sound like they are worth checking out. I appreciate the suggestions.

Regards,

Phil Nelson

Doh.... I totally missed that ... old age and failing eyesight haha
ok I'm not familiar with the cct of that particular scope, maybe there are places where you still can isolate downstream sections of various power rails and see if you can get it to stop tripping ??
does the manual have some faultfinding flow charts like my tek manual does ?
it made PSU faults pretty easy to narrow down to a particular board

cheers
Dave
 

Phil Nelson

Jul 5, 2010
5
Joined
Jul 5, 2010
Messages
5
Yah, the troubleshooting chart doesn't take you very far. It dead-ends with the question, "Are all voltages bad?"

Answer Yes: Troubleshoot preregulator and inverter circuitry (schematic 7)

Answer No: Troubleshoot faulty supply (schematic 7).

Everything's on the main board. Perhaps with an analog meter I can get a clue whether some supply voltages are normal and others are not.

Regards,

Phil
 
Top