Maker Pro
Maker Pro

troubleshooting lenovo v330-15IKB

titanico

May 9, 2023
2
Joined
May 9, 2023
Messages
2
Hello,

I'm struggling with a lenovo v330-15ikb. The computer had a bios problem, so I left it out for several months. When I wanted to fix it, I noticed that the battery was very low. I reloaded it manually and the voltage is again present at its output. But I’m weighing the circuit that handles fault detection to have it disabled by software. Can someone who has the same model try to turn on the pc without the internal battery connected please?

Thanks a lot.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
13,769
Joined
Nov 17, 2011
Messages
13,769
Sorry, I can't help with the original request as I don't have access to a computer of this model.

But: The NVRAM fo the compouter may be in a corrupt state due to the battery having been low. Try to let the computer sit without battery and without power supply for 12 hours or longer so any charge remaining on capacitors is completely discharged.

Or try a factory reset (warning: all data will be lost, so backup the hard drive first).

There's also a video for fixing bios issues.
 

titanico

May 9, 2023
2
Joined
May 9, 2023
Messages
2
Hi,

Thank you for your reply. Unfortunatly I already tried your cloues and did work. I even did read the register of the integrated circuits which are in charge of battery management and looks good for the main features. I got the schematics and figure out that the signal prochot# is always active even in sleep mode. Means that something is wrong with power supply. So my last resort is to ask someone to try boot the board without battery to identify if it's a battery or board issue.
 

Harald Kapp

Moderator
Moderator
Nov 17, 2011
13,769
Joined
Nov 17, 2011
Messages
13,769
Sorry to hear that. I whish you luck in repairing the issue.
 
Top