Maker Pro
Maker Pro

Truly embarrassed - help what have I done wrong

punkieys17

Feb 7, 2016
43
Joined
Feb 7, 2016
Messages
43
Talk about feeling stupid. This is the simplest of circuits. a BTB08-400B was used to switch a water pump via two reed switches that are triggered by magnetised floats in the pipes. The reed switches feed via resistor to the gate. So turn the tap on the flow starts and the floats rise triggering the thyristor. The resistor and thyristor were fried. Both were replaced...with a BTB08-600SRG (higher voltage tolerance) and the resistor I calculated at 12kOhms. The supply voltage is 230V - so call it 330V peak. The 12kOhm resistor gives a gate current of 330/12000= 27.5mA. The spec for the BTB08 says gate 5-50mA. With the reed switches definitely workimg properly the pump is running when it shouldn't. Put the power on and it runs when it should be stationary. Please help - its doing my brain in
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    18.1 KB · Views: 8

Alec_t

Jul 7, 2015
3,249
Joined
Jul 7, 2015
Messages
3,249
To help us to help you, please post the full schematic.
Are there any voltage spike suppression components? Do you have a pull-down resistor between gate and MT1 of the triac, to help prevent false triggering?
 

Kiwi

Jan 28, 2013
424
Joined
Jan 28, 2013
Messages
424
Shouldn't the reed switch be connected to the other side of the load?
 

Bluejets

Oct 5, 2014
5,995
Joined
Oct 5, 2014
Messages
5,995
Motors give high inductive spikes at startup and suspect that's what has killed it.
As above, show a full circuit of what you have, not what someone else has drawn up somewhere on the internet.

Include motor full load rating.
 
Top