Maker Pro
Maker Pro

Trying to repair a shaver charger

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
I took my cordless shaver to England with me recently (a Wahl model 8900). Without thinking to use the transformer I brought with me, I plugged it into one of their 220 outlets using a plug adapter. I had a pop after some seconds and quickly unplugged it. I never tried using it after that and now that I'm back in the US, the charger won't charge the shaver. I opened the charging unit up and there isn't much inside except the one electronic component in the photo---I don't know what that component is called.

Can anyone recommend where I could get another of these components? I've tried searching on "Trio 00064-200" but can't find anything. It measures 1.5" x 1.25" and is a bit over 1" thick.

Or, could the problem be that I fried the actual shaver itself instead of the charging unit?

Thanks very much.
DSCN5170_zps586e15b7.jpg
 
Last edited:

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
Looks like a Transformer rectifier combination. I would check the Wahl website for a replacement. I would ohm out the primary side where it plugs in for continuity. If it reads a few ohms (ok) you may be able to carefully unpeel the plastic on the other side (where the black and red wire go) to reveal another component that has likely failed, like a bridge rectifier or diodes.
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Hi Peter and welcome to Electronics Point :)

I agree that it seems to be a combined transformer/rectifier, according to the specifications (1.2V DC output).

It's possible that the shaver is damaged, but I think that's unlikely.

The resistance of the primary will be more than a few ohms. Anything up to 1000Ω is probably OK. But most likely it will measure open circuit.

In that case, or if you don't have (and can't borrow) a multimeter to test it with, there may be a thermal fuse in there that has failed (unwrap the green tape around the fat winding and see if you can find anything in there apart from wire) but probably not; it's probably the actual primary wire that has failed - somewhere inside that fat winding.

If that's the case, dismantle it as much as possible - remove the tape surrounding the laminated iron core and try to remove the core by levering against the white plastic bobbin with a screwdriver - and remove the tape enclosing the thinner winding (that the red and black wires emerge from). Then take some photos of what you find inside, plus a clearer photo of the label.
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
Thanks for the replies. I'm pretty good with household electric but not electronics so thank you for stepping me though this. I took some photos of what I think you asked me to do using my multimeter.

I'm not exactly sure what you mean by "primary"

Before I start opening the unit up, let me know if I did the test you had asked for and what the results indicate.

Thanks!

DSCN5174_zpsddb680d5.jpg
DSCN5177_zps472ec466.jpg
DSCN5178_zpsc60d9731.jpg

DSCN5172_zps74032670.jpg
DSCN5173_zps2fc0c649.jpg
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Right, that's good. The primary winding is the blue wires. It reads open circuit. That's the normal way that a transformer will fail if you plug it into twice the rated voltage.

See how far you can dismantle the transformer. If you can remove the tape around the windings, do that first. Otherwise you may need to remove the tape around the outside of the core (the tape that the label is attached to) and prise the core apart, so you can get to the bobbin more easily.

I don't think it's likely that the transformer will be repairable, but we need to know what's inside there, especially what's connected in the secondary part (red and black wires), so we can suggest a way to replace it.
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
I removed a few layers of the green tape around the winding with the red & black wires. I stopped when I noticed the end of the black wire was very loose and the only thing it is connected to is one strand of copper wire that disappears into the windings.

The red wire appears solid.

Should I keep dismantling to see what else is inside?

DSCN5183_zps8bcb0625.jpg
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Yes, keep going. It doesn't matter if you break the wire since you won't be able to repair it.

Were you not able to prise the iron core apart?
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Also, can you post any technical information you have on the shaver, and the instructions for charging. Is the battery removable? Can you find out anything about it?
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
I didn't know what "prise" meant so looked it up and it sounds like using leverage to get it open. I couldn't get the iron surround to open at any seams, even using a screwdriver and hammer. I did get more of the red/green wire section open though its all pretty mangled now. I removed the copper windings and under that is a metal enclosure. I think to open it any more would basically require just whacking it all with a hammer unless there is some trick to getting the iron surround to come apart.

I will see what other information I can find out about the shaver and post that momentarily.

Thanks.

DSCN5185_zps0ec09c76.jpg
DSCN5184_zps3b41f820.jpg
 
Last edited:

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
The battery inside the shaver can be replaced. I opened up the case and took some photos. The instructions that I read online for this shaver (I don't have the original manual that came with the shaver 20 years ago but the same model is still available) say to charge it 16 hours the first time. I've never had to change the rechargeable battery.

DSCN5190_zpsce860e94.jpg
DSCN5196_zps4a97de5c.jpg
DSCN5197_zps550f72cc.jpg
DSCN5203_zps3dd9daf7.jpg
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
OK, so it's a 1.2V 1500 mAh Ni-Cd cell. Recommended charging rate 450~500 mA for 5 hours.

I can't find any suitable transformer to replace it but you would be better to use a little power supply module anyway. These are available with 3.3V output, which must be dropped down to 1.2V. This is most easily done with diodes and resistors in series. Here is the connection diagram.

272479.001.GIF

Here is the component list from Digi-Key.

AC-DC converter:
http://www.digikey.com/product-detail/en/VSK-S2-3R3U/102-2590-ND/3316492 OR
http://www.digikey.com/product-detail/en/RAC02-3.3SC/945-1404-5-ND/2652157
Diode (two required):
http://www.digikey.com/product-detail/en/1N4001G/1N4001GOS-ND/1485468
Resistor:
http://www.digikey.com/product-detail/en/FMP200JR-52-3R3/3.3ZCT-ND/2059006

The component cost is about USD 15 plus shipping, which I hope isn't a problem.

Edit:

That circuit doesn't regulate the charging current very closely. You will have to do some experimentation to find out how long it takes to fully charge the shaver. If it takes too long, you can try a lower resistance for R1, and vice versa.

If anyone else has any other suggestions that might be cheaper and/or better, please say so!
 

Jeffrey Vazquez

Jan 29, 2015
1
Joined
Jan 29, 2015
Messages
1
This thread I am looking to participate because this frequently happened with me that my shaver gets out of use & have to replace the battery every time.
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
Thanks very much for all your help Kris. I will order the parts you suggest and give an update on how it went.
 

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
3.3−0.8−0.8(diode vd)
=1.7volts

1.7÷0.5amps
=3.4ohms?

I don't get it, I was thinking it'd be 1ohm to leave 1.2v left over.
 
Last edited:

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
It's pretty rough because the diode VF varies somewhat with IF and there is no defined end-of-charge condition.

Diode VF(typ) also varies slightly with manufacturer, but is generally around 0.8V at 100 mA and 0.9V at 500 mA. Ideally you want the charge current to taper off fairly sharply as the terminal voltage reaches the full charge point, but the terminal voltage doesn't vary much, and without a proper regulator you can't get a sharp taper anyway.

I looked for single-chip charge controllers but couldn't find anything suitable. Linear Technology make one that would do it, but it's a switching converter, so he would have had to add an inductor, catch diode, etc. I didn't want to suggest that.

Remember, the original solution is also pretty loosely defined.

You're probably right that the resistor should be a lower value. I was more concerned with avoiding damage to the NiCd than with ensuring the shortest recharge time.

Peter, if you haven't ordered the parts yet, you could order some other resistor values. One of each of these:

http://www.digikey.com/product-detail/en/FMP100JR-52-0R47/0.47WCT-ND/2058882
http://www.digikey.com/product-detail/en/FMP100JR-52-1R/1.0WCT-ND/2058906
http://www.digikey.com/product-detail/en/FMP200JR-52-1R5/1.5ZCT-ND/2058983
http://www.digikey.com/product-detail/en/FMP200JR-52-2R2/2.2ZCT-ND/2058996
http://www.digikey.com/product-detail/en/FMP200JR-52-4R7/4.7ZCT-ND/2059015
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
Kris, No, I thought I'd wait a few days before ordering in case there were any changes. I'm confused though so please be patient with my limited electronic knowledge. You had originally suggested one resistor and now you have suggested five others. Should I then order all 6 that you've mentioned or just the last 5? And, would I solder these resistors anywhere along the black wire leaving the converter before it reaches the charging contacts? Thanks.
 

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
I understand, just wondering how you arrived at 3.3ohms. Agreed, there is no charge regulation just like the original equipment had. So as the battery reaches full charge the current should drop to a low level. Even if it was plugged in for a long period of time the 220ma would not cause a problem. Right?
 

Tha fios agaibh

Aug 11, 2014
2,240
Joined
Aug 11, 2014
Messages
2,240
Peter, I believe Kris is proposing resistors as alternative values for experimentation purposes.
The original 3.3 ohm value may be off from the ideal charging voltage.
They are inexpensive enough to get them all, and try one at a time. Start with the higher ohm number (higher resistance) first which will make the charging voltage lower. Take note how long it takes to charge. I would note the initial voltage at the battery terminal everything 30 minutes or so until the 5 hour charge time elapsed. After 5 hours (dead battery) it should be achieve the full 1.2 volts. if its too slow or does not reach voltage, I would run the battery down and test it again with the next lower value resistor on another day.
 

PeterC

Jan 28, 2015
15
Joined
Jan 28, 2015
Messages
15
I received my parts and I'm about to solder. Here is a photo to show you my plan.

Are the diodes and resistor pointing in the correct directions and connecting to the correct terminal on the power supply module?
Does it matter which end of the AC cord goes to which connection on the power supply module (N or L)?
I see this power supply module says it has an imput of 100-240Vac so I guess that means I won't fry it again if I plug it into a UK source?

Thanks!

DSCN5536_zps45c1c821.jpg
 
Top