Maker Pro
Maker Pro

Trying to repair our VFD

Dan00

Mar 20, 2017
3
Joined
Mar 20, 2017
Messages
3
Hi everyone

we had a ABB ach550 used for pump and accidentally my co worker splashed some water and after checking it the drive wont turn on my question is how would i know the brand or type of ic we had on this board theres only number printed on it 314 241 any info would be great and also im new to the forum

Thanks
 

Attachments

  • ic.jpg
    ic.jpg
    3.6 KB · Views: 111

73's de Edd

Aug 21, 2015
3,637
Joined
Aug 21, 2015
Messages
3,637
3.6 kb density won't cut it on that photo.
If using Cmos circuity in that area, are you sure that water hasn't seeped and creeped and is still having moisture / wetness hidden?
Try a heating of the potentially affected area with a blow dryer

73's de Edd
 

davenn

Moderator
Sep 5, 2009
14,297
Joined
Sep 5, 2009
Messages
14,297
Hi everyone

we had a ABB ach550 used for pump and accidentally my co worker splashed some water and after checking it the drive wont turn on my question is how would i know the brand or type of ic we had on this board theres only number printed on it 314 241 any info would be great and also im new to the forum

Thanks

please post a much larger pic .... say around 800 x 600 so that we can see what you are referring to
 

shrtrnd

Jan 15, 2010
3,876
Joined
Jan 15, 2010
Messages
3,876
The next time you splash water on a printed circuit board, DO NOT reapply power until you use 73's de Edd's advice on COMPLETELY drying the PCB. The water didn't zap your device by itself, reapplying power to a wet board did.
Why are you convinced the IC (that we can't see in your photo) is the problem?
I used to work ABB VFDs. They've got engineers at the factory that know what that chip is if you don't have a schematic. (If you talk to a cooperative one) Your number is a proprietary one known only to ABB, and they'll want you to send the board to them for repair or replacement. Did you try Googleing cross references for ABB part numbers? Frankly, I'm trying to figure-out how you determined that this one IC is the problem.
If it is blown, it may have taken-out other components on the board as well.
 

shrtrnd

Jan 15, 2010
3,876
Joined
Jan 15, 2010
Messages
3,876
Are you kidding *steve*?
I could barely see the IC.
How in the heck could I see missing pieces of it?
My 10 1/2" x 18" computer monitor isn't big enough?
What're you using, one of those big-screen jobs?
I need to get me one of those. Couldn't be my old worn-out peepers, just got me a new pair of glasses.
 

Alec_t

Jul 7, 2015
3,647
Joined
Jul 7, 2015
Messages
3,647
The blown chip has no heatsink so would normally have been dissipating little power. Its dramatic demise is probably a side-effect of something else drawing excessive current.
 

Dan00

Mar 20, 2017
3
Joined
Mar 20, 2017
Messages
3
IMAG0027.jpg
my apologies heres the full image as i have checked the fuses and other parts were ok. also im convinced that this part needs to be replaced as the the first pin from the left showed some corrosion and missing pin Service technician came and didnt even bother checking only suggested to install whole new unit sir shrtrnd do you have schematics for this model ? sir 73's i have checked and disassembled the whole unit no moisture observed in the inner part just this ic showed some issue

thanks
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
The chunks I saw appear to be marks on a conformal coating.

Your first task now is to identify what is written on that chip. From this view we can't see anything. Maybe you can if the lighting is coming from another angle. Maybe the markings have been removed :-(
 

Dan00

Mar 20, 2017
3
Joined
Mar 20, 2017
Messages
3
hi steve theres only number written on it 314 241. maybe my best option is desolder this ic and show it to the parts store.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
That sounds like an internal part number. These are used to obscure the part that is being used and/or to integrate with an internal parts system.

You can look for a cross reference. Companies like HP would occasionally include relevant information in their service manuals, for others they were completely proprietry.
 

Alec_t

Jul 7, 2015
3,647
Joined
Jul 7, 2015
Messages
3,647
The component to the left of that IC looks unhealthy, too.
 

shrtrnd

Jan 15, 2010
3,876
Joined
Jan 15, 2010
Messages
3,876
No, sorry, I don't have the schematics on an ach550.
Again, you might try getting them from ABB (or Google them).
... I realize you're convinced this one IC is your problem. How did you determine that?
From visual inspection?
Have you got more than one of these boards, maybe in another on-site VFD.
Can you compare voltage test points and determine exactly where the failure is?
 
Top