Maker Pro
Maker Pro

Variable Current and Voltage Regulator - LM317T

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
I am trying to make a Variable Current and Voltage Regulator. But somehow, when I use the following circuit with 180ohm R1 and 10K Pot, I get the voltage I require but not the current. Current is always low. What is the problem with the CKT?

lm317t-voltage-regulation-circuit.gif
 

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
Nothing, except that it is not a current regulator, it is a voltage regulator.

You do understand, also, that you cannot control current and voltage independently? If you want a constant current, the voltage will vary with the load, if you want a constant voltage, the current will vary with the load.

Bob
 

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
I understand that. But I have to power a 5Watt LED from a 12 V source. The voltage for 5W LED is approx 6-7V and at 700mA. I cn go down to 6.6 V by adjusting the POT but the brightness is too low.

What should I do to make it work?
 

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
But wont that icrease or decrease the voltage to keep the current constant? Wont that burn the led if it tends to increase the voltage to keep the current constant?
 

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
Please check my circuit as well.
 

Attachments

  • lm317.jpg
    lm317.jpg
    128 KB · Views: 12,677

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
But wont that icrease or decrease the voltage to keep the current constant? Wont that burn the led if it tends to increase the voltage to keep the current constant?
LEDs are rated for current. The voltage varies from one to the next even of the same type. The LED will not be destroyed as long as you don't exceed the max current. However, for a 5 Watt LED, you WILL need heat sinking or you will destroy it by overheating.

Bob
 

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
Please check my circuit as well.

It is wired wrong. The output to the LED should come from the middle lead of the LM317. However, I stronly reccommend that you use the constant current mode instead. That is the proper way to drive high power LEDs. You will also need heat sinking on the LM317, by the way. Do not wire it up for 700ma without heat sinking or you are likely to blow one or the other of the components. You can try it at about 100ma if you do not have the heat sink capability.

Bob
 
Last edited:

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
One thing I am getting strange. If I Input the current from Vout of lm317 I get good current and voltage, LED if bright. But if I input the current from Vin of LM317, the LED is very dim and adjusting the POT only dims it more. Why its happening?
 

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
You have the LED connected to the adjust terminal in the photo you posted. Did you correct that?

One thing I am getting strange. If I Input the current from Vout of lm317 I get good current and voltage, LED if bright. But if I input the current from Vin of LM317, the LED is very dim and adjusting the POT only dims it more. Why its happening?

What do you mean by "input the current from Vout" The Vout pin is the pin that ought to be connected to the LED. Is this what you mean? If so that is what is supposed to happen, so what is the problem?

Bob
 

yoyom

Jan 1, 2013
22
Joined
Jan 1, 2013
Messages
22
Please look at the pic. If I connect + of battery to pin 1, then I get a very dim LED at pin 2. But if I connect + of battery to 2 pin, I get adjustable, bright LED output at 1.

One thing more, if I make it to control voltage, it allows very small current around 500mA.

I connected it to 5W led and worked fine, but when I connected it to a 10W led, it flowing the same current at almost double the voltage. I am not adding capacitors, does their absence is causing it allow small amount of current while keeping the Voltage constant?
 

Attachments

  • Untitled-1.jpg
    Untitled-1.jpg
    11.5 KB · Views: 527
Last edited:

BobK

Jan 5, 2010
7,682
Joined
Jan 5, 2010
Messages
7,682
Please read my posts #8 and #10. You are not connecting it correctly. The LED should be connected to the center pin (Vout).
And the battery plus terminal should be connected to pin 1 (Vin) in your diagram.

If you insist on wiring it incorrectly, I cannot help you.

Bob
 
Last edited:

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
In the new thread,

You didn't start a new thread. I have moved all the posts from this thread that I think are about something new to this new thread here.
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
That's probably because you SHOULD be using a constant current regulator, but despite our best advice you want to use a resistor.
 
Top