Maker Pro
Maker Pro

With Micro-Cap to call a model ?

J

jfk1948

Jan 1, 1970
0
Hello,

I used Micro-Cap9, the good demo version simulateur of Spectrum.
My question is about using a model.
- I defined the model in file jfet.lib, as follow :
..model J2N3819 NJF(Beta=1.304m Rd=1 Rs=1 Lambda=2.25m Vto=-3
+ Is=33.57f Cgd=1.6p Pb=1 Fc=.5 Cgs=2.414p Kf=9.882E-18 Af=1)
- in the file nom.lib, I declared as follow :
.lib "jfet.lib"
When I place a component in the shematic, then clic on the component,
I named MODEL= J2N3819, and I obtained an error.
Where is the problem ?
Help me please.

Regards JF.
 
Hello,

I used Micro-Cap9, the good demo version simulateur of Spectrum.
My question is about using a model.
- I defined the model in file jfet.lib, as follow :
.model J2N3819 NJF(Beta=1.304m Rd=1 Rs=1 Lambda=2.25m Vto=-3
+ Is=33.57f Cgd=1.6p Pb=1 Fc=.5 Cgs=2.414p Kf=9.882E-18 Af=1)
- in the file nom.lib, I declared as follow :
  .lib "jfet.lib"
When I place a component in the shematic, then clic on the component,
I named MODEL= J2N3819, and I obtained an error.
Where is the problem ?
Help me please.

Regards JF.

What is the error message you are getting? I'm guessing that it
either can't find the file or the model. I had this happen to me one
time. I saved the library file in Wordpad as Mylibrary.lib, but
Wordpad appended the .TXT extension automatically so it was unable to
find the library as I thought I had saved it. If it can't find the
library file this may be the reason. Also make sure that you placed
the library file in the same folder as the other libraries that come
with the Micro-Cap demo.
 
J

jfk1948

Jan 1, 1970
0
Don't search now, I have found the problem.
My error was simply a incorrect syntax in the jfet.lib file.

<[email protected]> a écrit dans le message de [email protected]m...
Hello,

I used Micro-Cap9, the good demo version simulateur of Spectrum.
My question is about using a model.
- I defined the model in file jfet.lib, as follow :
.model J2N3819 NJF(Beta=1.304m Rd=1 Rs=1 Lambda=2.25m Vto=-3
+ Is=33.57f Cgd=1.6p Pb=1 Fc=.5 Cgs=2.414p Kf=9.882E-18 Af=1)
- in the file nom.lib, I declared as follow :
.lib "jfet.lib"
When I place a component in the shematic, then clic on the component,
I named MODEL= J2N3819, and I obtained an error.
Where is the problem ?
Help me please.

Regards JF.

What is the error message you are getting? I'm guessing that it
either can't find the file or the model. I had this happen to me one
time. I saved the library file in Wordpad as Mylibrary.lib, but
Wordpad appended the .TXT extension automatically so it was unable to
find the library as I thought I had saved it. If it can't find the
library file this may be the reason. Also make sure that you placed
the library file in the same folder as the other libraries that come
with the Micro-Cap demo.
 
Top