Maker Pro
Maker Pro

Yamaha PS-35

Dirty Contact

Nov 24, 2012
22
Joined
Nov 24, 2012
Messages
22
The transistor driving the LED is T10 and there is no resistor in that line. There is a 68 ohm in before D89 is that the one? If so, when a key is pressed and the Master Vol. is at its bottom position a loud note issues from spkrs. and also from phones when they are inserted and the voltage across the 68 ohm resistor is 0.54v. as the slider of the M. Switch is moved the sound drops to almost inaudible and the voltage drops to zero. If anything it should be the other way round.
 

Dirty Contact

Nov 24, 2012
22
Joined
Nov 24, 2012
Messages
22
Steve, I have removed the Master Vol.Control top carrying the slider, cleaned it all up and put it back. As long as i keep pressure on it everything works as it should!! You thought it was the problem in the beginning so I owe you an apology for that. The fault created some very strange and misleading effects which was so puzzling. I am now researching for a sliding pot to replace this one. I think it is a Bourn make or Alp, not sure. It is 10K and slider action is 25mm in a 35mm case which is 8mm wide and 5.5mm high. Do you have any idea where I might get one?
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,505
Joined
Jan 21, 2010
Messages
25,505
Don't worry, faults like that can be tricky.

Getting a replacement can be even trickier.

There are two approaches. The first is to identify the part and to search the manufacturers web site or datasheets to find the modern equivalent (if the part is no longer available.

The second is to search (say digikey) for pots with the same dimensions to see if there is anything which might be compatible.

Unless you're lucky and find the part is still available (use findchips.com if you have a part number) you may have to use a combination of both of these and all the sites you can search on... digikey, element14, RS, etc...
 
Top