Maker Pro
Maker Pro

Realistic STA-2100D

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
I think it has something to do with the output boards.I l also found one blown output transistor and have pulled both right and left output boards.One Checks out good the other one has some of the transistors are not reading the same as on the good board.
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
Well,I disconnected both amplifier output boards,unplugging the main power supply capacitors on both channels.Turned the receiver on with my bulb dimmer.Everything lit up,Heard one relay click and the power button went from red to green.If I power off and connect either power board in,unit powers on with lights but stays in protect mode.Not sure where to start looking!Anyone have some suggestions?Output transistors test good on both channels.
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
Anyone know where I can obtain a volume balance part like this one for a STA-2100D receiver?This one is no good.Thanks!
 

Attachments

  • 0FBCACD3-6062-4ECF-AE34-B5EA17498691.jpeg
    0FBCACD3-6062-4ECF-AE34-B5EA17498691.jpeg
    273.3 KB · Views: 41
  • 261E521D-76A2-417D-A4D0-9A2C44B6845A.jpeg
    261E521D-76A2-417D-A4D0-9A2C44B6845A.jpeg
    286.9 KB · Views: 39
  • A39F66A9-1590-49AB-B399-4B53AF95DF80.jpeg
    A39F66A9-1590-49AB-B399-4B53AF95DF80.jpeg
    269.2 KB · Views: 34

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
That part is likely to be almost pure unobtainium.

What's wrong with it?
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
The volume part and the balance part turn together.Like they were welded together.Cannot separate them
 

73's de Edd

Aug 21, 2015
3,623
Joined
Aug 21, 2015
Messages
3,623
Sir tomcat65 . . . . .

The volume and balance control are supposed to be "clutched" together.
You bring up the volume knob up to a high enough mono source evaluative level and then adjust the separate balance where both speaker channels then equate in level .
Thereafterwards, as the volume adjustment is changed, the balance remains in tracking at all volume levels.

*** Since you now have the naked control bank . . . . install the two knobs so that you will have some "torque amplification " and then HOLD hold the volume knob immobile and then see if the separate balance knob can then be adjusted . . .in either direction . . .between its full ~270 degree range.
Then you will see that the balance setting will be retained as both controls rotate simultaneously, when only the volume control is rotated.
OR . . . but I have never seen it happen . . . .that internal contamination has actually physically locked the two controls rotation capabilities together and the *** operation above cannot be achieved.

Next we go back to the drawing board / schematic, if the control is actually normally clutched /tracking.

73's de Edd
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
When I put the balance control knob on and held the volume control with pliers,balance knob will not move.Not sure what has happened but no longer works.
 

Attachments

  • EDDA72C1-6766-4671-9471-050CFB1F18CB.jpeg
    EDDA72C1-6766-4671-9471-050CFB1F18CB.jpeg
    172.6 KB · Views: 30

Externet

Aug 24, 2009
891
Joined
Aug 24, 2009
Messages
891
Check if the shafts engage/disengage clutch by pulling or pushing one relative to the other.
And treat that control with love, may not be replaceable. Holding with pliers may deform its barrel and bind.
 
Last edited:

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
What does it mean when my sta-2100D receiver running off dimmer bulb,at low volume,the bulb is barely lit.As I turn up the volume,the light gets brighter!!Any thoughts?
 

(*steve*)

¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd
Moderator
Jan 21, 2010
25,510
Joined
Jan 21, 2010
Messages
25,510
That's pretty much what you expect to happen.
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
When one channel is out,can there still be a. Problem with the power supply or is it more probable to be that amps output board?There has to be something wrong somewhere,as the minute I connect up the left channel board,I hear the protection relay.
 

tomcat65

Jun 23, 2018
24
Joined
Jun 23, 2018
Messages
24
Hello.Anyone know where I can purchase a new 24 VDC speaker relay unit for a Realistic sta -2100D receiver?The one in there now is buzzing and cutting out the left speaker output.It says type MS-40 24 VDC on the plastic cover followed by DEO 029 Japan.I believe it has 8 pins,2 rows of four pins and 2 solder connections above the 2 rows of pins.Any help would be greatly appreciated!!!!
 

daddy60

Nov 8, 2018
4
Joined
Nov 8, 2018
Messages
4
Hello.Anyone know where I can purchase a new 24 VDC speaker relay unit for a Realistic sta -2100D receiver?The one in there now is buzzing and cutting out the left speaker output.It says type MS-40 24 VDC on the plastic cover followed by DEO 029 Japan.I believe it has 8 pins,2 rows of four pins and 2 solder connections above the 2 rows of pins.Any help would be greatly appreciated!!!!
Mouser has one that works. MY4-02 dc24 Omron automation
 

daddy60

Nov 8, 2018
4
Joined
Nov 8, 2018
Messages
4
The 2100 turns on with A relay working. Power light goes to green. No audio output.
I checked the transformer, large filter caps, full wave bridge rectifier, and these were all in working order. I checked the transistors around the B relay. All appeared to be ok. B relay does not activate with the delay after A relay. I see no need to check the dc balance or idling current at this time. Which transistors on power board or protection board might be bad? All fuses are ok. I need help please. Tr601 and Tr604 act funny when I check collector to emitter and collector to base. Could it be the bridge rectifier on the power board? there are only 4 transistors on the power board but, I have not tested these yet. I know I sound like I am kind of nuts but this thing has driven me there. I have another one that does not power up either. But it does not come on at all. I checked the transformer on this one and it was ok. I really need help with the first one.

Does anyone have suggestions on which capacitors (audio grade) would be best on the power board, preamp, and amp boards? I looked at nichicon but I am not sure which one to use where. the unit is fairly clean and I am getting ready to give it the works for cleaning.
thank you.
 

kellys_eye

Jun 25, 2010
6,514
Joined
Jun 25, 2010
Messages
6,514
Tr601 and Tr604 act funny when I check collector to emitter and collector to base.
'Act funny' isn't a technical term I recognise.

References to part numbers isn't very useful when we don't have a schematic to compare to.

Post the schematic and any pictures of the circuit boards you have.
 

daddy60

Nov 8, 2018
4
Joined
Nov 8, 2018
Messages
4
The 2100 turns on with A relay working. Power light goes to green. No audio output.
I checked the transformer, large filter caps, full wave bridge rectifier, and these were all in working order. I checked the transistors around the B relay. All appeared to be ok. B relay does not activate with the delay after A relay. I see no need to check the dc balance or idling current at this time. Which transistors on power board or protection board might be bad? All fuses are ok. I need help please. Tr601 and Tr604 act funny when I check collector to emitter and collector to base. Could it be the bridge rectifier on the power board? there are only 4 transistors on the power board but, I have not tested these yet. I know I sound like I am kind of nuts but this thing has driven me there. I have another one that does not power up either. But it does not come on at all. I checked the transformer on this one and it was ok. I really need help with the first one.

Does anyone have suggestions on which capacitors (audio grade) would be best on the power board, preamp, and amp boards? I looked at nichicon but I am not sure which one to use where. the unit is fairly clean and I am getting ready to give it the works for cleaning.
thank you.
I am talking ABOUT THE 2100 NOT THE 2100D
'Act funny' isn't a technical term I recognise.

References to part numbers isn't very useful when we don't have a schematic to compare to.

Post the schematic and any pictures of the circuit boards you have.
WORKING ON GETTING THE FILE. IT IS TOO LARGE. I AM TRYING TO FIND A WAY TO MAKE IT SMALLER. I WILL SEND PICTURES.
 

Ylli

Jun 19, 2018
405
Joined
Jun 19, 2018
Messages
405
Service manual available at https://elektrotanya.com/realistic_sta-2100_sm.pdf/download.html.

Relay "A" = relay associated with TR1301, the soft start board?
Relay "B" = relay associated with TR601 connecting the audio outputs to the speaker terminals?

Are you sure relay "B" is not pulling in? With power on, what is the voltage on terminal 1 of the protect board? (This is the junction of D601/C601/TR606-E)
 
Top