Maker Pro
Maker Pro

Adding Aux input to older car stereo

Status
Not open for further replies.

DoubleDogDan

Jul 20, 2014
24
Joined
Jul 20, 2014
Messages
24
I was able to pull the CD assy & locate the junctions of R507/C504 & R 508/C505. Attached are pics of the foil pattern at the location, and also a shot of the actual components. Pretty straightforward electronically, just sever the conductor at the 2 res/cap junctions & insert the switched jack appropriately. Unfortunately, my experience with surface mount components is limited, and I'm a bit leery of how to solder the leads at these locations, particularly on the cap sides. Looks like I'd have to solder on the inboard attachment point of each cap, but again, with limited experience on these tiny components, I'm afraid the entire cap will come loose. I do have a couple small irons, but still. Note that the pad between the res's & cap's is only about 1mm in diameter, not sure it's large enough to attach to. I'm referring to the small dot to the left of each cap, I'll use the leads to the left of that point for the res side of each connection. Suggestions? Also, I'm assuming that in terms of the ground on the jack itself, that this can be connected at any ground point?

Thanks,

Dan


foil pattern.jpg pcb.jpg
 
Last edited:

Gryd3

Jun 25, 2014
4,098
Joined
Jun 25, 2014
Messages
4,098
Ok looks like your on the road to doing this yourself, cool. I heard of these things a few years ago, might not be what you want but might be of interest in the future.

http://www.amazon.co.uk/s/?ie=UTF8&keywords=mp3 transmitter for car radio&tag=googhydr-21&index=aps&hvadid=26788691214&hvpos=1t1&hvexid=&hvnetw=g&hvrand=1367805496983981270&hvpone=&hvptwo=&hvqmt=b&hvdev=c&ref=pd_sl_8qht6b81jf_b

Cheers
Adam
Those work great in a pinch... but the audio quality can be pretty bad. You need to find a clear FM band to use if your area, and will need to adjust it if you travel.
I would recommend this to anyone who does not want to invest time or money into their vehicle.
 

DoubleDogDan

Jul 20, 2014
24
Joined
Jul 20, 2014
Messages
24
Adam - Thanks for the suggestion. I have seen those, but the reviews of them aren't usually too great, saying the sound is a bit like AM radio, and as Gryd3 says, you need a freq. unused in your area. Pretty cheap, though, I'll probably have more in the jack & shipping on this mod!
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
OK, here's what I suggest.

pcb mod.png

Cut the two tracks between PA51 and R507 and R508, at the points marked with the red Xes. A good way to do this is using a pair of sharp side cutters, held vertically, with one point anchored to the board in the area indicated by the "A" and the arrow. You can drill a hole part way into the board in that area to serve as the anchor point for the side cutters. Then, while pushing the side cutters into the anchor hole, bring the other point down onto the tracks and gently open and close the side cutters to cut the tracks. As you cut through the track by opening and closing the side cutters, move the cutting point down until the track is cut all the way through.

Alternatively, get a sharp scalpel from a modelling supply store, and cut the tracks carefully, holding the scalpel just behind the blade and resting your fingers on the board to get fine control. Imagine that you're cutting into a tree with an axe, and the track is the bark of the tree. You need to make two cuts at sharp angles to each other, to make a V-shaped channel cutting through the track and slightly into the PCB material, crosswise to the track. For each cut, press the scalpel firmly into the board and slice across the track. Since you're only making a shallow cut, this will not be hard. When the two cuts meet, the piece of track will just fall out.

Then connect your five wires to the points marked with blue dots. Three of them (the two switched contacts, and the common) can be soldered to the pads where the pins of the radio receiver IC (PA51) come through the board. You may want to remove the old solder first, and make a quick clean joint covering the pad, the PA51 pin, and the wire. (Twist and tin the wire first.) The other two wires can be soldered directly onto the ends of the SMT resistors R507 and R508.

You can use two stereo screened cables, or ideally, a single screened cable with four conductors inside it. The screen(s) connect to the common. If you use two cables, connect both screens to common at the PCB, but only connect one screen at the socket end.

When you strip the wire, unweave the screen (if it's woven) and twist it tightly into a wire. At the PCB end, keep this wire short (less than 1/4") so it anchors the cable to the PCB, and have some slack in the four conductor wires, so if the cable gets pulled, it won't break the thin wires or pull the SMT resistors off the board.

I think I recommended using a socket with a metal collar going through the panel, for rigidity. But if the panel is metal, it's probably better to use the cheaper type of socket with a plastic collar, so the socket is isolated from the metalwork. Otherwise there are two parallel connections between the socket's common (the "sleeve" of the plug) and the circuit's common rail, assuming that the panel is metal and is already connected to circuitry common.
 

DoubleDogDan

Jul 20, 2014
24
Joined
Jul 20, 2014
Messages
24
Kris - Thanks for the reply. What you've suggested is pretty much what I had planned, except you're using the PA51 pins & resistor pad, while I was leaning towards the pins & the cap pads. No real difference which one, I guess. My concern was that the soldering at the end of either component (that pad) would possibly free the entire surface mount component, which I'm not very experienced with working around. I plan to apply the minimal amount of heat required, but is this a real issue? They are actually glued to the PCB, in addition to being held in place by the solder joints, correct? For the cable, I have a length of 4 conductor shielded PS/2 cable from a broken computer keyboard I was planning to use. I'm still not sure if I'll mount the jack, or just have it "dangling", so as to avoid drilling the dash. Given the low cost of the jacks, I'll probably order one of each of the 3 you suggested which are 3.5mm (one was 1/4"). Probably start with this one http://www.digikey.com/scripts/DkSearch/dksus.dll?Detail&itemSeq=154081504&uq=635417463139420584 although it's PCB mount, I can solder to the lugs, and it looks beefier than the other 2.

Please let me know if this sounds like a plan & I'll order the jacks. Let me say again that I really appreciate the time you've spent to respond to my questions. Thanks!

Dan
 

KrisBlueNZ

Sadly passed away in 2015
Nov 28, 2011
8,393
Joined
Nov 28, 2011
Messages
8,393
Whether they're glued or not depends on how the board was assembled. If it was flow-soldered, which is what it looks like (I think - I'm no expert on this), then they should be glued, but don't assume that they are. Just make connections quickly, and if you need to connect to both ends (you don't for this job), make sure the first end has cooled down before you start with the second.

Here's the step-by-step for how I would do it, using a low power soldering iron with a fine tip and a solder sucker with a fine tip.

Heat up the end of the SMT component that you want to connect to, and quickly suck the solder off. If you didn't get all of it, wait for it to cool down and try again. Get the wire ready - stripped, twisted, tinned, and cut to length. With the board held firmly in position, use something like "helping hands" (alligator clips attached to a heavy base) to hold the wire (not close to the end, otherwise the alligator clip may cut into the insulation when the wire heats up) so that the tinned end section rests along the end of the SMT component and against the pad, i.e. along the corner formed between them. Heat up the pad and feed solder in to fully enclose the wire and remake the connection to the component.

Edit:

Re the cable, that sounds fine. The screen may not be very good, but it doesn't really need to be for this project. If you have the socket free-hanging, I would use one with a metal collar and put it inside a metal container like an old aluminium camera film canister or an aluminium vitamin tablet container or similar. Rig up some kind of strain relief from the cable to the container, and if possible, slide on a tapered support to prevent it being bent at a sharp angle near the canister. Cover the canister with something non-conductive such as sticky label or sticky plastic book covering, so it can't touch anything.
 
Last edited:

Arouse1973

Adam
Dec 18, 2013
5,178
Joined
Dec 18, 2013
Messages
5,178
Adam - Thanks for the suggestion. I have seen those, but the reviews of them aren't usually too great, saying the sound is a bit like AM radio, and as Gryd3 says, you need a freq. unused in your area. Pretty cheap, though, I'll probably have more in the jack & shipping on this mod!

That's fair enough I didn't know what they were like , I guessed which way you were heading anyway.
Adam
 

DoubleDogDan

Jul 20, 2014
24
Joined
Jul 20, 2014
Messages
24
It works! The contact sizes made it one of the futzier soldering jobs I've ever done, but the PS/2 cable is perfect, just the right diameter to both fit through an existing hole in the radio chassis, as well as to hold the cable firmly against the PCB when the cover is attached (but without too much pressure). Sound is just as it is when I run these players through computer speakers. It's going to be so great using these devices through the car audio, rather than having to use earbuds in the car. One thing I noticed; if you pause the mp3 player & turn the head unit volume to max, you can hear the tiniest bit of radio audio. I'm guessing that this is because, while the radio audio is disconnected by the jack switches, the receiver portion of the system is still receiving power. I'm guess when CD is inserted (or on newer units with an AUX setting) the receiver is powered down when these other sources are "on". Again, not a real issue, you can BARELY hear it with VOL maxed & MP3 paused, and not at all when MP3 is playing. I am wondering though Kris if there was a reason you chose to insert the input at the radio output, rather than at the CD player output?

I'm on another forum for this particular car (a 2003 Mitsubishi Lancer Evolution), and I'll probably post a link to this for anyone there who might like to try it, though this is probably not for someone with little or no electronics experience, and a VERY small soldering iron.

Thanks to all who helped, and especially Kris. I appreciate your time very much!

Dan
 

DoubleDogDan

Jul 20, 2014
24
Joined
Jul 20, 2014
Messages
24
I'm the OP on this one, & got an email update showing your post. My setup behaves EXACTLY the same way! I mostly use a Sandisk MP3 player, which has worked great from the get go, but I got an Android "smart" phone (lollipop OS) about a year after I posted this, and it did just what you describe the 1st time I tried it (playing out the phone's speaker, not sending the signal out the headphone jack). I figured it was just the $%#@%%^ thing "thinking" too much, and never tried it again, until I saw your post just now. The phone plays thru the system if connected as you describe, but only when I disconnect/reconnect at the head unit! I'm guessing the headphone jack in the phone is triggering this somehow, but at least there's a "workaround"! Thanks so much for passing this on, I haven't tried it since it failed that 1st time.

Dan
 

Gryd3

Jun 25, 2014
4,098
Joined
Jun 25, 2014
Messages
4,098
What happened to the post I just replied to?!?
No idea. Possible that someone decided to spam links of other garbage and got a one-way ticket to ban-town.
Our admins can make people disappear ;)
 

davenn

Moderator
Sep 5, 2009
14,296
Joined
Sep 5, 2009
Messages
14,296
I'm the OP on this one, & got an email update showing your post. My setup behaves EXACTLY the same way! I mostly use a Sandisk MP3 player, which has worked great from the get go, but I got an Android "smart" phone (lollipop OS) about a year after I posted this, and it did just what you describe the 1st time I tried it (playing out the phone's speaker, not sending the signal out the headphone jack). I figured it was just the $%#@%%^ thing "thinking" too much, and never tried it again, until I saw your post just now. The phone plays thru the system if connected as you describe, but only when I disconnect/reconnect at the head unit! I'm guessing the headphone jack in the phone is triggering this somehow, but at least there's a "workaround"! Thanks so much for passing this on, I haven't tried it since it failed that 1st time.

what happened to the post I just responded to?!

I had obviously moved that post to its own new thread before you had a chance to respond
that guys post is now in the circuit help section

since this is a really old thread of yours, I will close it to save any other confusion


Dave
 
Last edited:
Status
Not open for further replies.
Top